Approved changes feed: RSS · Atom

cpe:2.3:a:vega_project:vega:*:*:*:*:*:node.js:*:*

part: a version: * update: *

VendorVega Project (704d3b66-5759-5fa7-809d-54c8d056ea76)
ProductVega (adfa46b8-63fe-5b65-9bd8-ac869e0831e7)
Edition*
Language*
Software edition*
Target softwarenode.js
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:deb/debian/vega.js purl2cpe 2026-06-01 10:16:50.360326
pkg:github/vega/vega purl2cpe 2026-06-01 10:16:50.360328
pkg:maven/org.webjars.bower/vega purl2cpe 2026-06-01 10:16:50.360329
pkg:maven/org.webjars.npm/vega purl2cpe 2026-06-01 10:16:50.360331
pkg:npm/vega purl2cpe 2026-06-01 10:16:50.360332

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-65110 vulnerable 2026-06-08 07:39:20.723126 Vega Cross-Site Scripting (XSS) via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope
HIGH (8.1)
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to versions 6.1.2 and 5.6.3, applications meeting two conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. First, they use `vega` in an application that attaches both `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window`, or has any other satisfactory function gadgets in the global scope. Second, they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). This vulnerability allows for DOM XSS, potentially stored, potentially reflected, depending on how the library is being used. The vulnerability requires user interaction with the page to trigger. An attacker can exploit this issue by tricking a user into opening a malicious Vega specification. Successful exploitation allows the attacker to execute arbitrary JavaScript in the context of the application’s domain. This can lead to theft of sensitive information such as authentication tokens, manipulation of data displayed to the user, or execution of unauthorized actions on behalf of the victim. This exploit compromises confidentiality and integrity of impacted applications.Patched versions are available in `vega-selections@6.1.2` (requires ESM) for Vega v6 and `vega-selections@5.6.3` (no ESM needed) for Vega v5. As a workaround, do not attach `vega` or `vega.View` instances to global variables or the window as the editor used to do. This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties.
Published: 2026-01-05T21:22:35.941Z
Updated: 2026-01-05T21:48:24.823Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-26619 vulnerable 2026-06-08 07:14:49.529159 Vega Cross-Site Scripting (XSS) via event filter when not using CSP mode `expressionInterpeter`
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In `vega` 5.30.0 and lower and in `vega-functions` 5.15.0 and lower , it was possible to call JavaScript functions from the Vega expression language that were not meant to be supported. The issue is patched in `vega` `5.31.0` and `vega-functions` `5.16.0`. Some workarounds are available. Run `vega` without `vega.expressionInterpreter`. This mode is not the default as it is slower. Alternatively, using the interpreter described in CSP safe mode (Content Security Policy) prevents arbitrary Javascript from running, so users of this mode are not affected by this vulnerability.
Published: 2025-03-27T13:51:38.442Z
Updated: 2025-03-27T14:21:44.479Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-26487 vulnerable 2026-06-08 05:57:39.797425 Vega has cross-site scripting vulnerability in `lassoAppend` function
MEDIUM (6.5)
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs.`lassoAppend' function accepts 3 arguments and internally invokes `push` function on the 1st argument specifying array consisting of 2nd and 3rd arguments as `push` call argument. The type of the 1st argument is supposed to be an array, but it's not enforced. This makes it possible to specify any object with a `push` function as the 1st argument, `push` function can be set to any function that can be access via `event.view` (no all such functions can be exploited due to invalid context or signature, but some can, e.g. `console.log`). The issue is that`lassoAppend` doesn't enforce proper types of its arguments. This issue opens various XSS vectors, but exact impact and severity depends on the environment (e.g. Core JS `setImmediate` polyfill basically allows `eval`-like functionality). This issue was patched in 5.23.0.
Published: 2023-03-03T23:47:28.486Z
Updated: 2025-02-25T15:01:54.570Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-26486 vulnerable 2026-06-08 05:57:39.796891 Vega `scale` expression function cross site scripting
MEDIUM (6.5)
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. The Vega `scale` expression function has the ability to call arbitrary functions with a single controlled argument. The scale expression function passes a user supplied argument group to getScale, which is then used as if it were an internal context. The context.scales[name].value is accessed from group and called as a function back in scale. This can be exploited to escape the Vega expression sandbox in order to execute arbitrary JavaScript. This issue has been fixed in version 5.13.1.
Published: 2023-03-03T23:48:41.382Z
Updated: 2025-02-25T15:01:48.054Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2020-26296 vulnerable 2026-06-08 05:23:51.161639 XSS in Vega
HIGH (8.7)
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Vega in an npm package. In Vega before version 5.17.3 there is an XSS vulnerability in Vega expressions. Through a specially crafted Vega expression, an attacker could execute arbitrary javascript on a victim's machine. This is fixed in version 5.17.3
Published: 2020-12-30T23:10:16.000Z
Updated: 2024-08-04T15:56:04.125Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.