Approved changes feed: RSS · Atom

cpe:2.3:a:yt-dlp_project:yt-dlp:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorYt Dlp Project (4b5b0e1c-cb38-5753-b3bc-6549a377dff4)
ProductYt Dlp (5af79b5e-9283-5345-a342-b61e60980b50)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:deb/debian/yt-dlp purl2cpe 2026-06-01 10:17:01.727805
pkg:deb/ubuntu/yt-dlp purl2cpe 2026-06-01 10:17:01.727810
pkg:github/yt-dlp/yt-dlp purl2cpe 2026-06-01 10:17:01.727813
pkg:pypi/yt-dlp purl2cpe 2026-06-01 10:17:01.727817
pkg:rpm/fedora/yt-dlp purl2cpe 2026-06-01 10:17:01.727821
pkg:rpm/opensuse/yt-dlp purl2cpe 2026-06-01 10:17:01.727824
pkg:sourceforge/yt-dlp.mirror purl2cpe 2026-06-01 10:17:01.727828

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-26331 vulnerable 2026-06-08 07:53:21.518746 yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option
HIGH (8.8)
yt-dlp is a command-line audio/video downloader. Starting in version 2023.06.21 and prior to version 2026.02.21, when yt-dlp's `--netrc-cmd` command-line option (or `netrc_cmd` Python API parameter) is used, an attacker could achieve arbitrary command injection on the user's system with a maliciously crafted URL. yt-dlp maintainers assume the impact of this vulnerability to be high for anyone who uses `--netrc-cmd` in their command/configuration or `netrc_cmd` in their Python scripts. Even though the maliciously crafted URL itself will look very suspicious to many users, it would be trivial for a maliciously crafted webpage with an inconspicuous URL to covertly exploit this vulnerability via HTTP redirect. Users without `--netrc-cmd` in their arguments or `netrc_cmd` in their scripts are unaffected. No evidence has been found of this exploit being used in the wild. yt-dlp version 2026.02.21 fixes this issue by validating all netrc "machine" values and raising an error upon unexpected input. As a workaround, users who are unable to upgrade should avoid using the `--netrc-cmd` command-line option (or `netrc_cmd` Python API parameter), or they should at least not pass a placeholder (`{}`) in their `--netrc-cmd` argument.
Published: 2026-02-24T02:23:40.858Z
Updated: 2026-02-24T20:08:47.720Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-54072 vulnerable 2026-06-08 07:33:11.108342 yt-dlp allows `--exec` command injection when using placeholder on Windows
HIGH (7.5)
yt-dlp is a feature-rich command-line audio/video downloader. In versions 2025.06.25 and below, when the --exec option is used on Windows with the default placeholder (or {}), insufficient sanitization is applied to the expanded filepath, allowing for remote code execution. This is a bypass of the mitigation for CVE-2024-22423 where the default placeholder and {} were not covered by the new escaping rules. Windows users who are unable to upgrade should avoid using --exec altogether. Instead, the --write-info-json or --dump-json options could be used, with an external script or command line consuming the JSON output. This is fixed in version 2025.07.21.
Published: 2025-07-22T21:34:43.408Z
Updated: 2025-07-23T18:30:06.761Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-3566 vulnerable 2026-06-08 06:41:53.598113 Command injection vulnerability in programing languages on Microsoft Windows operating system.
A command inject vulnerability allows an attacker to perform command injection on Windows applications that indirectly depend on the CreateProcess function when the specific conditions are satisfied.
Published: 2024-04-10T15:22:56.099Z
Updated: 2025-11-18T17:35:41.547Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-22423 vulnerable 2026-06-08 06:29:34.924329 yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows
HIGH (8.4)
yt-dlp is a youtube-dl fork with additional features and fixes. The patch that addressed CVE-2023-40581 attempted to prevent RCE when using `--exec` with `%q` by replacing double quotes with two double quotes. However, this escaping is not sufficient, and still allows expansion of environment variables. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2024.04.09 fixes this issue by properly escaping `%`. It replaces them with `%%cd:~,%`, a variable that expands to nothing, leaving only the leading percent. It is recommended to upgrade yt-dlp to version 2024.04.09 as soon as possible. Also, always be careful when using `--exec`, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade, avoid using any output template expansion in `--exec` other than `{}` (filepath); if expansion in `--exec` is needed, verify the fields you are using do not contain `"`, `|` or `&`; and/or instead of using `--exec`, write the info json and load the fields from it instead.
Published: 2024-04-09T17:22:58.751Z
Updated: 2025-02-13T17:33:45.700Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-46121 vulnerable 2026-06-08 06:12:43.885826 Generic Extractor MITM Vulnerability in yt-dlp
MEDIUM (5)
yt-dlp is a youtube-dl fork with additional features and fixes. The Generic Extractor in yt-dlp is vulnerable to an attacker setting an arbitrary proxy for a request to an arbitrary url, allowing the attacker to MITM the request made from yt-dlp's HTTP session. This could lead to cookie exfiltration in some cases. Version 2023.11.14 removed the ability to smuggle `http_headers` to the Generic extractor, as well as other extractors that use the same pattern. Users are advised to upgrade. Users unable to upgrade should disable the Ggneric extractor (or only pass trusted sites with trusted content) and ake caution when using `--no-check-certificate`.
Published: 2023-11-14T23:31:55.145Z
Updated: 2024-08-29T15:19:23.948Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-40581 vulnerable 2026-06-08 06:11:03.684049 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.