Wp Members
Approved changes feed: RSS · Atom
cpe:2.3:a:butlerblog:wp-members:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Butlerblog (295dac00-567a-5ce9-8727-dd9510a3dabe) |
|---|---|
| Product | Wp Members (ad5a30be-0f3c-547b-855f-1ecc3024056d) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/butlerblog/wp-members |
purl2cpe | 2026-06-01 10:17:09.713237 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-14448 |
vulnerable | 2026-06-08 07:06:34.506712 |
WP-Members Membership Plugin <= 3.5.4.3 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Multiple Checkbox and Multiple Select User Profile Fields
MEDIUM (5.4)
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Multiple Checkbox and Multiple Select user profile fields in all versions up to, and including, 3.5.4.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-01-15T05:24:19.163Z
Updated: 2026-04-08T17:05:34.094Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-9231 |
vulnerable | 2026-06-08 07:00:26.970895 |
WP-Members Membership Plugin <= 3.4.9.5 - Reflected Cross-Site Scripting
MEDIUM (6.1)
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.4.9.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2024-10-22T09:32:09.502Z
Updated: 2026-04-08T16:44:10.725Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-1987 |
vulnerable | 2026-06-08 06:27:15.197718 |
WP-Members Membership Plugin <= 3.4.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
MEDIUM (6.4)
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 3.4.9.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-03-08T05:31:47.330Z
Updated: 2026-04-08T16:57:14.927Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-1852 |
vulnerable | 2026-06-08 06:27:14.704765 |
WP-Members Membership Plugin <= 3.4.9.2 - Unauthenticated Stored Cross-Site Scripting
HIGH (7.2)
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.
Published: 2024-04-09T18:58:29.359Z
Updated: 2026-04-08T16:32:49.679Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-10374 |
vulnerable | 2026-06-08 06:23:46.330722 |
WP-Members <= 3.4.9.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpmem_loginout Shortcode
MEDIUM (6.4)
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpmem_loginout shortcode in all versions up to, and including, 3.4.9.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-10-25T11:36:09.533Z
Updated: 2026-04-08T16:56:12.986Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-6733 |
vulnerable | 2026-06-08 06:21:55.397268 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-2869 |
vulnerable | 2026-06-08 06:02:43.563834 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2019-15660 |
vulnerable | 2026-06-08 05:12:57.764605 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-2222 |
vulnerable | 2026-06-08 05:09:23.914878 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.