Svg Support
Approved changes feed: RSS · Atom
cpe:2.3:a:benbodhi:svg_support:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Benbodhi (6d89218c-c001-5d7f-9844-c5bbe05f13c2) |
|---|---|
| Product | Svg Support (0b3e099f-c54c-565f-b6b2-b742cf086282) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/wp-plugins/svg-support |
purl2cpe | 2026-06-01 10:17:12.751355 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-48973 |
vulnerable | 2026-06-08 08:05:12.382070 |
WordPress SVG Support plugin <= 2.5.14 - Broken Access Control vulnerability
MEDIUM (4.3)
Missing Authorization vulnerability in Benbodhi SVG Support allows Exploiting Incorrectly Configured Access Control Security Levels.
This issue affects SVG Support: from n/a through 2.5.14.
Published: 2026-05-27T14:28:59.191Z
Updated: 2026-05-27T15:34:08.377Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-10222 |
vulnerable | 2026-06-08 06:22:03.802015 |
SVG Support <= 2.5.10 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
MEDIUM (6.4)
The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 2.5.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file. By default, this can only be exploited by administrators, but the ability to upload SVG files can be extended to authors.
Published: 2025-02-21T13:41:28.666Z
Updated: 2026-04-08T16:54:34.119Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-6708 |
vulnerable | 2026-06-08 06:21:55.348520 |
SVG Support <= 2.5.7 - Authenticated (Author+) Cross-Site Scripting via SVG
MEDIUM (5.4)
The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the SVG upload feature in all versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping, even when the 'Sanitize SVG while uploading' feature is enabled. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note that successful exploitation of this vulnerability requires the administrator to allow author-level users to upload SVG files. As of 2.5.6, SVG sanitization can still be bypassed by supplying a content-type other than image/svg+xml.
Published: 2024-07-18T02:38:33.871Z
Updated: 2026-04-08T17:00:49.641Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4022 |
vulnerable | 2026-06-08 05:51:36.571823 |
Details available
MEDIUM (6.4)
The SVG Support plugin for WordPress defaults to insecure settings in version 2.5 and 2.5.1. SVG files containing malicious javascript are not sanitized. While version 2.5 adds the ability to sanitize image as they are uploaded, the plugin defaults to disable sanitization and does not restrict SVG upload to only administrators. This allows authenticated attackers, with author-level privileges and higher, to upload malicious SVG files that can be embedded in posts and pages by higher privileged users. Additionally, the embedded JavaScript is also triggered on visiting the image URL, which allows an attacker to execute malicious code in browsers visiting that URL.
Published: 2022-11-16T13:23:44.784Z
Updated: 2025-02-07T20:32:49.213Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.