Approved changes feed: RSS · Atom
cpe:2.3:a:arc53:docsgpt:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Arc53 (9c66ad09-1e39-55ba-af68-59f72bd165b3) |
|---|---|
| Product | Docsgpt (e262e26c-efb7-588d-92a3-a2d52858b057) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from purl2cpe mapping |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/arc53/docsgpt |
purl2cpe | 2026-06-01 10:17:37.579638 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-91201 |
vulnerable | 2026-09-16 04:32:55.475335 |
DocsGPT through 0.20.0 OAuth Token Disclosure via Wildcard postMessage
MEDIUM (5.4)
DocsGPT through 0.20.0 posts OAuth connector session tokens to a wildcard target origin in the callback-status endpoint without validating sender origin. Attackers can obtain session tokens and provider account emails by acting as window.opener during OAuth authorization, then use tokens to disconnect victims' cloud storage connectors.
Published: 2026-09-14T22:10:58.067Z
Updated: 2026-09-24T14:22:18.178Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-13483 |
vulnerable | 2026-07-29 00:23:33.077258 |
arc53 DocsGPT Credential Storage encryption.py encrypt_credentials data authenticity
LOW (3.1)
A flaw has been found in arc53 DocsGPT up to 0.18.0. The affected element is the function encrypt_credentials of the file application/security/encryption.py of the component Credential Storage. This manipulation causes insufficient verification of data authenticity. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is described as difficult. The exploit has been published and may be used. The pull request to fix this issue awaits acceptance.
Published: 2026-06-28T05:45:08.860Z
Updated: 2026-06-29T13:01:38.042Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-26015 |
vulnerable | 2026-06-08 07:53:20.721477 |
Unauthenticated RCE in DocsGPT MCP STDIO Configuration
DocsGPT is a GPT-powered chat for documentation. From version 0.15.0 to before version 0.16.0, an attacker accessing both the official DocsGPT website or any local and public deployment, can craft a malicious payload bypassing the "MCP test" behavior to achieve arbitrary remote code execution (RCE). This issue has been patched in version 0.16.0.
Published: 2026-04-29T17:37:25.524Z
Updated: 2026-05-06T19:43:48.147Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-0868 |
vulnerable | 2026-06-08 07:02:25.733883 |
Remote Code Execution in DocsGPT
A vulnerability, that could result in Remote Code Execution (RCE), has been found in DocsGPT. Due to improper parsing of JSON data using eval() an unauthorized attacker could send arbitrary Python code to be executed via /api/remote endpoint..
This issue affects DocsGPT: from 0.8.1 through 0.12.0.
Published: 2025-02-20T11:26:11.784Z
Updated: 2025-10-03T08:56:10.028Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-31451 |
vulnerable | 2026-06-08 06:35:31.548754 |
Limited file write in routes.py (GHSL-2023-250)
MEDIUM (5.3)
DocsGPT is a GPT-powered chat for documentation. DocsGPT is vulnerable to unauthenticated limited file write in routes.py. This vulnerability is fixed in 0.8.1.
Published: 2024-04-16T14:28:11.435Z
Updated: 2024-08-02T01:52:56.966Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.