Approved changes feed: RSS · Atom
cpe:2.3:a:pwntools_project:pwntools:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Pwntools Project (245b2a9a-b238-5983-afad-15066d3c6508) |
|---|---|
| Product | Pwntools (31ac9aac-e1be-5113-8a2e-210882eacf41) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:docker/pwntools/pwntools |
purl2cpe | 2026-06-01 10:17:42.246431 |
pkg:github/gallopsled/pwntools |
purl2cpe | 2026-06-01 10:17:42.246434 |
pkg:pypi/pwntools |
purl2cpe | 2026-06-01 10:17:42.246437 |
pkg:rpm/fedora/python-pwntools |
purl2cpe | 2026-06-01 10:17:42.246439 |
pkg:sourceforge/pwntools.mirror |
purl2cpe | 2026-06-01 10:17:42.246442 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2020-28468 |
vulnerable | 2026-06-08 05:23:56.114570 |
Improper Control of Generation of Code ('Code Injection')
HIGH (8.1)
This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.
Published: 2021-01-08T11:20:13.794Z
Updated: 2024-09-16T23:22:02.072Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.