Flask Security Too
Approved changes feed: RSS · Atom
cpe:2.3:a:flask-security-too_project:flask-security-too:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Flask Security Too Project (8d153bee-4465-58de-9e3b-76c63e207c8b) |
|---|---|
| Product | Flask Security Too (e4c2356c-b8a9-5a14-8799-ca7cdab804ec) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/flask-middleware/flask-security |
purl2cpe | 2026-06-01 10:17:49.178811 |
pkg:pypi/flask-security-too |
purl2cpe | 2026-06-01 10:17:49.178813 |
pkg:rpm/fedora/python-flask-security-too |
purl2cpe | 2026-06-01 10:17:49.178816 |
pkg:rpm/opensuse/python-flask-security-too |
purl2cpe | 2026-06-01 10:17:49.178819 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-49438 |
vulnerable | 2026-06-08 06:14:29.100934 |
Details available
An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.
Published: 2023-12-26T00:00:00.000Z
Updated: 2025-11-04T18:19:40.464Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-21241 |
vulnerable | 2026-06-08 05:29:11.450939 |
CSRF can expose users authentication token in Flask-Security-Too
HIGH (7.4)
The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to "0" (seconds) which should make the token unusable.
Published: 2021-01-11T20:35:16.000Z
Updated: 2024-08-03T18:09:15.009Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.