Approved changes feed: RSS · Atom

cpe:2.3:a:yeken:snippet_shortcodes:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorYeken (f2d5d0df-0a4d-5397-8c45-373805fbfbd8)
ProductSnippet Shortcodes (0e7a2651-6293-5182-bd40-90a63f8ed0cb)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/wp-plugins/shortcode-variables purl2cpe 2026-06-01 10:17:55.304724

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-4543 vulnerable 2026-06-08 06:50:18.080556 Snippet Shortcodes <= 4.1.4 - Cross-Site Request Forgery
MEDIUM (4.3)
The Snippet Shortcodes plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.1.4. This is due to missing or incorrect nonce validation when adding or editing shortcodes. This makes it possible for unauthenticated attackers to modify shortcodes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2024-07-03T04:31:32.014Z
Updated: 2026-04-08T16:36:25.775Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.