Approved changes feed: RSS · Atom
cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Htmlunit (ac2b38e9-0a55-52fe-b424-5842e55a4350) |
|---|---|
| Product | Htmlunit (08ea2975-5bf0-5546-b9d5-0f9439ea4761) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/htmlunit/htmlunit |
purl2cpe | 2026-06-01 10:17:56.925203 |
pkg:maven/org.htmlunit/htmlunit |
purl2cpe | 2026-06-01 10:17:56.925206 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-49093 |
vulnerable | 2026-06-08 06:14:28.477658 |
HtmlUnit vulnerable to Remote Code Execution (RCE) via XSTL
CRITICAL (9.8)
HtmlUnit is a GUI-less browser for Java programs. HtmlUnit is vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage. This vulnerability has been patched in version 3.9.0
Published: 2023-12-04T04:47:27.145Z
Updated: 2024-10-10T20:14:07.250Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-2798 |
vulnerable | 2026-06-08 06:02:43.023454 |
Denial of service in HtmlUnit
HIGH (7.5)
Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). If HtmlUnit is running on user supplied web pages, an attacker may supply content that causes HtmlUnit to crash by a stack overflow. This effect may support a denial of service attack.This issue affects htmlunit before 2.70.0.
Published: 2023-05-25T13:54:52.191Z
Updated: 2024-08-02T06:33:05.702Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-26119 |
vulnerable | 2026-06-08 05:57:38.658319 |
Details available
CRITICAL (9.8)
Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.
Published: 2023-04-03T05:00:02.503Z
Updated: 2026-10-08T21:14:02.638Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-29546 |
vulnerable | 2026-06-08 05:42:48.457187 |
Details available
HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.
Published: 2022-04-25T02:54:59.000Z
Updated: 2026-11-02T22:04:14.906Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-28366 |
vulnerable | 2026-06-08 05:42:44.441204 |
Details available
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Published: 2022-04-21T22:41:53.000Z
Updated: 2024-08-03T05:56:15.220Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-5529 |
vulnerable | 2026-06-08 05:26:43.016205 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.