Approved changes feed: RSS · Atom

cpe:2.3:a:wp-guppy:wp_guppy:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorWp Guppy (61e41083-1bfa-5f79-b13d-43bc5f90d180)
ProductWp Guppy (e890e22f-c1f1-522f-b9a4-77c2ebb91c50)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/keyvanhardani/wp-guppy-a-live-chat-wp-json-api-sensitive-information-disclosure purl2cpe 2026-06-01 10:18:00.817178

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2021-24997 vulnerable 2026-06-08 05:30:39.769274 WP Guppy < 1.3 - Sensitive Information Disclosure
The WP Guppy WordPress plugin before 1.3 does not have any authorisation in some of the REST API endpoints, allowing any user to call them and could lead to sensitive information disclosure, such as usernames and chats between users, as well as be able to send messages as an arbitrary user
Published: 2021-12-27T10:33:26.000Z
Updated: 2024-08-03T19:49:14.595Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.