Approved changes feed: RSS · Atom

cpe:2.3:a:sismics:teedy:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSismics (352c7722-ee3a-55c1-9888-e4d8001ed6d2)
ProductTeedy (562a9799-61cf-5389-a1c3-e50e064b152d)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/sismics/docs purl2cpe 2026-06-01 10:18:07.417032

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-22963 vulnerable 2026-06-08 07:10:55.031516 Details available
HIGH (7.5)
Teedy through 1.11 allows CSRF for account takeover via POST /api/user/admin.
Published: 2025-01-13T00:00:00.000Z
Updated: 2025-08-12T13:27:52.613Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-11853 vulnerable 2026-06-08 07:04:29.313240 Sismics Teedy API Endpoint file access control
MEDIUM (6.3)
A vulnerability was determined in Sismics Teedy up to 1.11. This affects an unknown function of the file /api/file of the component API Endpoint. Executing a manipulation can lead to improper access controls. The attack may be performed from remote. The exploit has been publicly disclosed and may be utilized. The vendor was contacted early about this disclosure but did not respond in any way.
Published: 2025-10-16T19:02:07.747Z
Updated: 2026-02-24T07:00:48.654Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-54852 vulnerable 2026-06-08 06:54:16.845353 Details available
When LDAP connection is activated in Teedy versions between 1.9 to 1.12, the username field of the login form is vulnerable to LDAP injection. Due to improper sanitization of user input, an unauthenticated attacker is then able to perform various malicious actions, such as creating arbitrary accounts and spraying passwords.
Published: 2025-01-29T00:00:00.000Z
Updated: 2025-02-10T22:11:34.342Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-54851 vulnerable 2026-06-08 06:54:16.844843 Details available
Teedy <= 1.12 is vulnerable to Cross Site Request Forgery (CSRF), due to the lack of CSRF protection.
Published: 2025-01-29T00:00:00.000Z
Updated: 2025-01-30T16:48:20.198Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-22115 vulnerable 2026-06-08 05:40:05.915638 Teedy - Stored Cross-Site Scripting (XSS) in Tag Name
CRITICAL (9)
In Teedy, versions v1.5 through v1.9 are vulnerable to Stored Cross-Site Scripting (XSS) in the name of a created Tag. Since the Tag name is not being sanitized properly in the edit tag page, a low privileged attacker can store malicious scripts in the name of the Tag. In the worst case, the victim who inadvertently triggers the attack is a highly privileged administrator. The injected scripts can extract the Session ID, which can lead to full Account Takeover of the administrator, and privileges escalation.
Published: 2022-01-10T15:26:56.337Z
Updated: 2024-09-17T03:28:07.597Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-22114 vulnerable 2026-06-08 05:40:05.915034 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.