Approved changes feed: RSS · Atom

cpe:2.3:a:spice_project:spice:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSpice Project (e807e39a-eb6e-58e1-9aea-6143475c2c77)
ProductSpice (042bb133-75ea-5947-b59c-26e607f1cb51)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/freedesktop/spice purl2cpe 2026-06-01 10:18:09.602948
pkg:gitlab/redhat/spice purl2cpe 2026-06-01 10:18:09.602951
pkg:rpm/fedora/spice purl2cpe 2026-06-01 10:18:09.602954

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2021-20201 vulnerable 2026-06-08 05:29:08.703216 Details available
A flaw was found in spice in versions before 0.14.92. A DoS tool might make it easier for remote attackers to cause a denial of service (CPU consumption) by performing many renegotiations within a single connection.
Published: 2021-05-28T10:42:15.000Z
Updated: 2024-08-03T17:30:07.638Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2020-14355 vulnerable 2026-06-08 05:19:23.096174 Details available
Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1. Both the SPICE client (spice-gtk) and server are affected by these flaws. These flaws allow a malicious client or server to send specially crafted messages that, when processed by the QUIC image compression algorithm, result in a process crash or potential code execution.
Published: 2020-10-07T14:41:18.000Z
Updated: 2024-08-04T12:39:36.601Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2019-3813 vulnerable 2026-06-08 05:13:56.086783 Details available
Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.
Published: 2019-02-04T18:00:00.000Z
Updated: 2024-09-16T16:23:33.117Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-10873 vulnerable 2026-06-08 05:10:37.261633 Details available
HIGH (8.3)
A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.
Published: 2018-08-17T12:00:00.000Z
Updated: 2024-08-05T07:46:47.325Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2016-9578 vulnerable 2026-06-08 05:08:24.057102 Details available
HIGH (7.5)
A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An attacker able to connect to the SPICE server could send crafted messages which would cause the process to crash.
Published: 2018-07-27T21:00:00.000Z
Updated: 2024-08-06T02:59:02.515Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2016-9577 vulnerable 2026-06-08 05:08:24.056127 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-5261 vulnerable 2026-06-08 05:06:49.374614 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-5260 vulnerable 2026-06-08 05:06:49.372755 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2013-4130 vulnerable 2026-06-08 05:04:34.082685 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.