Approved changes feed: RSS · Atom
cpe:2.3:a:simon_tatham:putty:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Simon Tatham (028e5a99-0a12-552a-a31f-7f988487cba5) |
|---|---|
| Product | Putty (e4cd4493-2350-547b-b7f4-d0f6efa8cabb) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from purl2cpe mapping |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:deb/debian/putty |
purl2cpe | 2026-06-01 10:18:20.134324 |
pkg:deb/ubuntu/putty |
purl2cpe | 2026-06-01 10:18:20.134327 |
pkg:github/github/putty |
purl2cpe | 2026-06-01 10:18:20.134330 |
pkg:github/kasperdeng/putty |
purl2cpe | 2026-06-01 10:18:20.134333 |
pkg:github/larryli/putty |
purl2cpe | 2026-06-01 10:18:20.134335 |
pkg:rpm/fedora/putty |
purl2cpe | 2026-06-01 10:18:20.134338 |
pkg:rpm/opensuse/putty |
purl2cpe | 2026-06-01 10:18:20.134341 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2016-2563 |
vulnerable | 2026-06-08 05:07:42.651987 |
Details available
Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.
Published: 2016-04-07T23:00:00.000Z
Updated: 2024-08-05T23:32:20.848Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-5309 |
vulnerable | 2026-06-08 05:06:49.551011 |
Details available
Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.
Published: 2015-12-07T20:00:00.000Z
Updated: 2024-08-06T06:41:09.521Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4852 |
vulnerable | 2026-06-08 05:04:49.964982 |
Details available
Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:59:40.996Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4208 |
vulnerable | 2026-06-08 05:04:34.616945 |
Details available
The rsa_verify function in PuTTY before 0.63 (1) does not clear sensitive process memory after use and (2) does not free certain structures containing sensitive process memory, which might allow local users to discover private RSA and DSA keys.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:38:01.962Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4207 |
vulnerable | 2026-06-08 05:04:34.616194 |
Details available
Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:38:01.696Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4206 |
vulnerable | 2026-06-08 05:04:34.614489 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.