Approved changes feed: RSS · Atom
cpe:2.3:a:yukihiro_matsumoto:ruby:1.6:*:*:*:*:*:*:*part: a version: 1.6 update: *
| Vendor | Yukihiro Matsumoto (66f60d31-e664-5f4f-903c-7ef102ff18b3) |
|---|---|
| Product | Ruby (5a70ffc3-f0b5-5cc0-a3e0-542009490292) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2006-1931 |
vulnerable | 2026-06-08 04:48:58.404703 |
Details available
The HTTP/XMLRPC server in Ruby before 1.8.2 uses blocking sockets, which allows attackers to cause a denial of service (blocked connections) via a large amount of data.
Published: 2006-04-20T21:00:00.000Z
Updated: 2024-08-07T17:27:29.579Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2005-2337 |
vulnerable | 2026-06-08 04:48:29.050638 |
Details available
Ruby 1.6.x up to 1.6.8, 1.8.x up to 1.8.2, and 1.9.0 development up to 2005-09-01 allows attackers to bypass safe level and taint flag protections and execute disallowed code when Ruby processes a program through standard input (stdin).
Published: 2005-10-07T04:00:00.000Z
Updated: 2024-08-07T22:22:48.597Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2004-0983 |
vulnerable | 2026-06-08 04:47:52.186789 |
Details available
The CGI module in Ruby 1.6 before 1.6.8, and 1.8 before 1.8.2, allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a certain HTTP request.
Published: 2004-11-19T05:00:00.000Z
Updated: 2024-08-08T00:38:59.645Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2004-0755 |
vulnerable | 2026-06-08 04:47:51.106731 |
Details available
The FileStore capability in CGI::Session for Ruby before 1.8.1, and possibly PStore, creates files with insecure permissions, which can allow local users to steal session information and hijack sessions.
Published: 2004-08-19T04:00:00.000Z
Updated: 2024-08-08T00:31:46.351Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.