Approved changes feed: RSS · Atom
cpe:2.3:a:yukihiro_matsumoto:ruby:1.8:*:*:*:*:*:*:*part: a version: 1.8 update: *
| Vendor | Yukihiro Matsumoto (66f60d31-e664-5f4f-903c-7ef102ff18b3) |
|---|---|
| Product | Ruby (5a70ffc3-f0b5-5cc0-a3e0-542009490292) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2006-6303 |
vulnerable | 2026-06-08 04:49:28.620103 |
Details available
The read_multipart function in cgi.rb in Ruby before 1.8.5-p2 does not properly detect boundaries in MIME multipart content, which allows remote attackers to cause a denial of service (infinite loop) via crafted HTTP requests, a different issue than CVE-2006-5467.
Published: 2006-12-06T19:00:00.000Z
Updated: 2024-08-07T20:19:35.192Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2006-5467 |
vulnerable | 2026-06-08 04:49:20.598592 |
Details available
The cgi.rb CGI library for Ruby 1.8 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via an HTTP request with a multipart MIME body that contains an invalid boundary specifier, as demonstrated using a specifier that begins with a "-" instead of "--" and contains an inconsistent ID.
Published: 2006-10-27T18:00:00.000Z
Updated: 2024-08-07T19:48:30.572Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2006-1931 |
vulnerable | 2026-06-08 04:48:58.409075 |
Details available
The HTTP/XMLRPC server in Ruby before 1.8.2 uses blocking sockets, which allows attackers to cause a denial of service (blocked connections) via a large amount of data.
Published: 2006-04-20T21:00:00.000Z
Updated: 2024-08-07T17:27:29.579Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2005-2337 |
vulnerable | 2026-06-08 04:48:29.055334 |
Details available
Ruby 1.6.x up to 1.6.8, 1.8.x up to 1.8.2, and 1.9.0 development up to 2005-09-01 allows attackers to bypass safe level and taint flag protections and execute disallowed code when Ruby processes a program through standard input (stdin).
Published: 2005-10-07T04:00:00.000Z
Updated: 2024-08-07T22:22:48.597Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2005-1992 |
vulnerable | 2026-06-08 04:48:28.032298 |
Details available
The XMLRPC server in utils.rb for the ruby library (libruby) 1.8 sets an invalid default value that prevents "security protection" using handlers, which allows remote attackers to execute arbitrary commands.
Published: 2005-06-20T04:00:00.000Z
Updated: 2024-08-07T22:06:57.994Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2004-0983 |
vulnerable | 2026-06-08 04:47:52.187845 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2004-0755 |
vulnerable | 2026-06-08 04:47:51.107311 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.