Approved changes feed: RSS · Atom

cpe:2.3:a:youtube_embed_project:youtube_embed:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorYoutube Embed Project (48e8de1d-5a09-5bfd-a681-ba682078eee0)
ProductYoutube Embed (f5678d6e-ab8f-53bf-9c86-89454e9ccc2b)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2021-24471 vulnerable 2026-06-08 05:30:04.436039 YouTube Embed < 5.2.2 - Contributor+ Stored XSS
The YouTube Embed WordPress plugin before 5.2.2 does not validate, escape or sanitise some of its shortcode attributes, leading to Stored XSS issues by 1. using w, h, controls, cc_lang, color, language, start, stop, or style parameter of youtube shortcode, 2. by using style, class, rel, target, width, height, or alt parameter of youtube_thumb shortcode, or 3. by embedding a video whose title or description contains XSS payload (if API key is configured).
Published: 2021-08-16T10:48:22.000Z
Updated: 2024-08-03T19:35:19.727Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-6535 vulnerable 2026-06-08 05:06:52.658271 Details available
Cross-site scripting (XSS) vulnerability in includes/options-profiles.php in the YouTube Embed plugin before 3.3.3 for WordPress allows remote administrators to inject arbitrary web script or HTML via the Profile name field (youtube_embed_name parameter).
Published: 2015-08-31T18:00:00.000Z
Updated: 2024-08-06T07:22:22.281Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.