Approved changes feed: RSS · Atom
cpe:2.3:a:wp-polls_project:wp-polls:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Wp Polls Project (c3fee102-e7fe-5f53-b2d8-7dca78a6ff92) |
|---|---|
| Product | Wp Polls (cde6f3f8-298d-5245-a6a7-e603fd2e9814) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-13426 |
vulnerable | 2026-06-08 06:25:37.660378 |
WP-Polls <= 2.77.2 - Unauthenticated SQL Injection to Stored Cross-Site Scripting
MEDIUM (5.4)
The WP-Polls plugin for WordPress is vulnerable to SQL Injection via COOKIE in all versions up to, and including, 2.77.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries. Those queries are stored and results are not displayed to the attacker, which means they cannot be exploited to obtain any additional information about the database. However, a properly configured payload allows for the injection of malicious JavaScript resulting in Stored Cross-Site Scripting.
Published: 2025-01-22T02:20:24.893Z
Updated: 2026-04-08T17:17:39.307Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-40130 |
vulnerable | 2026-06-08 05:48:22.919693 |
WordPress WP-Polls plugin <= 2.76.0 - Auth. Race Condition vulnerability
MEDIUM (4.3)
Auth. (subscriber+) Race Condition vulnerability in WP-Polls plugin <= 2.76.0 on WordPress.
Published: 2022-11-18T22:31:42.678Z
Updated: 2026-04-28T16:07:47.694Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-1581 |
vulnerable | 2026-06-08 05:39:13.491651 |
WP-Polls < 2.76.0 - IP Validation Bypass
The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.
Published: 2022-11-21T00:00:00.000Z
Updated: 2025-04-30T15:00:03.896Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2016-10936 |
vulnerable | 2026-06-08 05:07:25.864613 |
Details available
The wp-polls plugin before 2.73.1 for WordPress has XSS via the Poll bar option.
Published: 2019-08-27T12:04:29.000Z
Updated: 2024-08-06T03:38:56.748Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-9352 |
vulnerable | 2026-06-08 05:07:13.595248 |
Details available
The wp-polls plugin before 2.72 for WordPress has SQL injection.
Published: 2019-08-27T12:05:41.000Z
Updated: 2024-08-06T08:51:03.304Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.