Weblibrarian
Approved changes feed: RSS · Atom
cpe:2.3:a:deepsoft:weblibrarian:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Deepsoft (b1f529a5-305a-50ef-8017-764c435fe2e5) |
|---|---|
| Product | Weblibrarian (184d7947-1fd1-5126-975b-f2d4f6a0138b) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-29441 |
vulnerable | 2026-06-08 06:02:40.215560 |
WordPress WebLibrarian Plugin <= 3.5.8.1 is vulnerable to Cross Site Scripting (XSS)
HIGH (7.1)
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Robert Heller WebLibrarian plugin <= 3.5.8.1 versions.
Published: 2023-09-06T07:58:12.441Z
Updated: 2026-04-28T16:08:19.029Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2019-1010034 |
vulnerable | 2026-06-08 05:12:21.569861 |
Details available
Deepwoods Software WebLibrarian 3.5.2 and earlier is affected by: SQL Injection. The impact is: Exposing the entire database. The component is: Function "AllBarCodes" (defined at database_code.php line 1018) is vulnerable to a boolean-based blind sql injection. This function call can be triggered by any user logged-in with at least Volunteer role or manage_circulation capabilities. PoC : /wordpress/wp-admin/admin.php?page=weblib-circulation-desk&orderby=title&order=DESC.
Published: 2019-07-15T12:39:12.000Z
Updated: 2024-08-05T03:07:17.921Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-18540 |
vulnerable | 2026-06-08 05:09:11.229241 |
Details available
The weblibrarian plugin before 3.4.8.7 for WordPress has XSS via front-end short codes.
Published: 2019-08-21T11:59:06.000Z
Updated: 2024-08-05T21:28:55.260Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-18539 |
vulnerable | 2026-06-08 05:09:11.228921 |
Details available
The weblibrarian plugin before 3.4.8.6 for WordPress has XSS via front-end short codes.
Published: 2019-08-21T11:57:30.000Z
Updated: 2024-08-05T21:28:54.871Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-18538 |
vulnerable | 2026-06-08 05:09:11.228537 |
Details available
The weblibrarian plugin before 3.4.8.5 for WordPress has XSS via front-end short codes.
Published: 2019-08-21T11:56:13.000Z
Updated: 2024-08-05T21:28:55.269Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.