Approved changes feed: RSS · Atom

cpe:2.3:a:mondula:multi_step_form:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorMondula (e31749b5-4c53-5f4c-bdbd-1f1a6c88e324)
ProductMulti Step Form (de7b2db3-7f4d-5b47-8008-6b783d97f6b6)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-50428 vulnerable 2026-06-08 06:52:10.062875 WordPress Multi Step Form plugin <= 1.7.21 - Broken Access Control vulnerability
MEDIUM (4.3)
Missing Authorization vulnerability in mondula2016 Multi Step Form multi-step-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Multi Step Form: from n/a through <= 1.7.21.
Published: 2024-10-29T21:10:53.593Z
Updated: 2026-05-12T23:01:00.194Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-25905 vulnerable 2026-06-08 06:31:23.975415 WordPress Multi Step Form Plugin <= 1.7.18 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (5.4)
Cross-Site Request Forgery (CSRF) vulnerability in Mondula GmbH Multi Step Form.This issue affects Multi Step Form: from n/a through 1.7.18.
Published: 2024-02-21T06:47:53.978Z
Updated: 2026-04-28T16:09:13.184Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-12427 vulnerable 2026-06-08 06:23:51.934385 Multi Step Form <= 1.7.23 - Missing Authorization to Unauthenticated Limited File Upload
MEDIUM (5.3)
The Multi Step Form plugin for WordPress is vulnerable to unauthorized limited file upload due to a missing capability check on the fw_upload_file AJAX action in all versions up to, and including, 1.7.23. This makes it possible for unauthenticated attackers to upload limited file types such as images.
Published: 2025-01-16T09:39:15.810Z
Updated: 2026-04-08T17:32:17.199Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-50832 vulnerable 2026-06-08 06:16:16.818565 WordPress Multi Step Form Plugin <= 1.7.13 is vulnerable to Cross Site Scripting (XSS)
MEDIUM (5.9)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mondula GmbH Multi Step Form allows Stored XSS.This issue affects Multi Step Form: from n/a through 1.7.13.
Published: 2023-12-21T17:23:05.986Z
Updated: 2026-04-28T16:08:59.071Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-47758 vulnerable 2026-06-08 06:14:25.525579 WordPress Multi Step Form Plugin <= 1.7.11 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (5.4)
Cross-Site Request Forgery (CSRF) vulnerability in Mondula GmbH Multi Step Form plugin <= 1.7.11 versions.
Published: 2023-11-22T18:09:51.607Z
Updated: 2026-04-28T16:08:51.134Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-4196 vulnerable 2026-06-08 05:51:36.954166 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-14846 vulnerable 2026-06-08 05:10:53.590517 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-14430 vulnerable 2026-06-08 05:10:52.892817 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.