Approved changes feed: RSS · Atom
cpe:2.3:a:sanitize_project:sanitize:*:*:*:*:*:ruby:*:*part: a version: * update: *
| Vendor | Sanitize Project (01e6a65c-1caf-5eab-b6b6-5bb97e671d15) |
|---|---|
| Product | Sanitize (fdea13b3-e2f7-56c8-8fd5-073af157038d) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | ruby |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-36823 |
vulnerable | 2026-06-08 06:08:13.553790 |
Sanitize vulnerable to Cross-site Scripting via insufficient neutralization of `style` element content
HIGH (7.1)
Sanitize is an allowlist-based HTML and CSS sanitizer. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML and CSS through Sanitize starting with version 3.0.0 and prior to version 6.0.2 when Sanitize is configured to use the built-in "relaxed" config or when using a custom config that allows `style` elements and one or more CSS at-rules. This could result in cross-site scripting or other undesired behavior when the malicious HTML and CSS are rendered in a browser. Sanitize 6.0.2 performs additional escaping of CSS in `style` element content, which fixes this issue. Users who are unable to upgrade can prevent this issue by using a Sanitize config that doesn't allow `style` elements, using a Sanitize config that doesn't allow CSS at-rules, or by manually escaping the character sequence `</` as `<\/` in `style` element content.
Published: 2023-07-06T15:06:00.509Z
Updated: 2025-02-13T16:56:27.159Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-23627 |
vulnerable | 2026-06-08 05:56:04.115275 |
Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element
MEDIUM (6.1)
Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.
Published: 2023-01-27T23:44:17.617Z
Updated: 2025-03-10T21:17:49.562Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-4054 |
vulnerable | 2026-06-08 05:25:58.790685 |
Cross-site Scripting in Sanitize
HIGH (7.3)
In Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability. When HTML is sanitized using Sanitize's "relaxed" config, or a custom config that allows certain elements, some content in a math or svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: iframe, math, noembed, noframes, noscript, plaintext, script, style, svg, xmp. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. This has been fixed in 5.2.1.
Published: 2020-06-16T22:10:13.000Z
Updated: 2024-08-04T07:52:20.925Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2018-3740 |
vulnerable | 2026-06-08 05:11:41.206980 |
Details available
A specially crafted HTML fragment can cause Sanitize gem for Ruby to allow non-whitelisted attributes to be used on a whitelisted HTML element.
Published: 2018-03-30T19:00:00.000Z
Updated: 2024-08-05T04:50:30.616Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.