Supportcandy
Approved changes feed: RSS · Atom
cpe:2.3:a:supportcandy:supportcandy:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Supportcandy (6b89bc0e-10fb-5c8e-afd3-f40144ff6096) |
|---|---|
| Product | Supportcandy (a8a707c8-a6f2-5792-9605-4b299c196ba3) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-2805 |
vulnerable | 2026-06-08 06:02:43.034447 |
SupportCandy < 3.1.7 - Admin+ SQLi
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the agents[] parameter in the set_add_agent_leaves AJAX function before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Published: 2023-06-19T10:52:54.332Z
Updated: 2024-12-09T21:17:44.825Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-2719 |
vulnerable | 2026-06-08 06:02:42.885597 |
SupportCandy < 3.1.7 - Subscriber+ SQLi
The SupportCandy WordPress plugin before 3.1.7 does not properly sanitise and escape the `id` parameter for an Agent in the REST API before using it in an SQL statement, leading to an SQL Injection exploitable by users with a role as low as Subscriber.
Published: 2023-06-19T10:52:42.822Z
Updated: 2024-12-12T21:03:39.440Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-1730 |
vulnerable | 2026-06-08 05:52:36.862593 |
SupportCandy < 3.1.5 - Unauthenticated SQLi
The SupportCandy WordPress plugin before 3.1.5 does not validate and escape user input before using it in an SQL statement, which could allow unauthenticated attackers to perform SQL injection attacks
Published: 2023-05-02T07:05:01.073Z
Updated: 2025-01-30T14:23:35.538Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24880 |
vulnerable | 2026-06-08 05:30:39.550782 |
SupportCandy < 2.2.7 - Contributor+ Stored Cross-Site Scripting
The SupportCandy WordPress plugin before 2.2.7 does not validate and escape the page attribute of its shortcode, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks
Published: 2022-02-07T15:47:12.000Z
Updated: 2024-08-03T19:49:13.465Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24879 |
vulnerable | 2026-06-08 05:30:39.550450 |
SupportCandy < 2.2.7 - CSRF to Cross-Site Scripting
The SupportCandy WordPress plugin before 2.2.7 does not have CSRF check in the wpsc_tickets AJAX action, nor has any sanitisation or escaping in some of the filter fields which could allow attackers to make a logged in user having access to the ticket lists dashboard set an arbitrary filter (stored in their cookies) with an XSS payload in it.
Published: 2022-02-07T15:47:11.000Z
Updated: 2024-08-03T19:49:13.940Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24878 |
vulnerable | 2026-06-08 05:30:39.549997 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24843 |
vulnerable | 2026-06-08 05:30:39.339002 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24839 |
vulnerable | 2026-06-08 05:30:39.333270 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2019-11223 |
vulnerable | 2026-06-08 05:12:36.671702 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.