Stockdio Historical Chart
Approved changes feed: RSS · Atom
cpe:2.3:a:stockdio:stockdio_historical_chart:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Stockdio (0c0331b1-bc93-5e79-812a-1e3172a076c6) |
|---|---|
| Product | Stockdio Historical Chart (a02fe08e-b3f9-50db-b627-d39204cfe006) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-13349 |
vulnerable | 2026-06-08 06:25:37.349188 |
Stockdio Historical Chart <= 2.8.18 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The Stockdio Historical Chart plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'stockdio-historical-chart' shortcode in all versions up to, and including, 2.8.18 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-01-30T13:42:10.093Z
Updated: 2026-04-08T17:31:28.985Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-28707 |
vulnerable | 2026-06-08 05:23:56.455779 |
Details available
The Stockdio Historical Chart plugin before 2.8.1 for WordPress is affected by Cross Site Scripting (XSS) via stockdio_chart_historical-wp.js in wp-content/plugins/stockdio-historical-chart/assets/ because the origin of a postMessage() event is not validated. The stockdio_eventer function listens for any postMessage event. After a message event is sent to the application, this function sets the "e" variable as the event and checks that the types of the data and data.method are not undefined (empty) before proceeding to eval the data.method received from the postMessage. However, on a different website. JavaScript code can call window.open for the vulnerable WordPress instance and do a postMessage(msg,'*') for that object.
Published: 2021-01-19T21:58:38.000Z
Updated: 2026-07-09T00:11:48.837Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.