Approved changes feed: RSS · Atom
cpe:2.3:a:simplepress:simple:press_forum:*:*:*:*:*:*:*:*
part: a version: press_forum update: *
| Vendor | Simplepress (ee70f5c3-af8c-5436-8588-5442826a4ece) |
|---|---|
| Product | Simple (5fa65922-e905-5387-b666-645bd88823ba) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from gcve-enriched-dumps CVE data |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-13518 |
vulnerable | 2026-06-08 06:25:37.854122 |
Simple:Press <= 6.10.12 - Cross-Site Request Forgery to Unauthorized Post Editing
MEDIUM (4.3)
The Simple:Press Forum plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.10.12. This is due to missing or incorrect nonce validation on the 'sp_save_edited_post' function. This makes it possible for unauthenticated attackers to modify a forum post via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2025-03-01T04:21:49.340Z
Updated: 2026-04-08T16:49:23.963Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-12409 |
vulnerable | 2026-06-08 06:23:51.902255 |
Simple:Press Forum <= 6.10.11 - Reflected Cross-Site Scripting
MEDIUM (6.1)
The Simple:Press Forum plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 6.10.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2025-01-30T11:10:19.927Z
Updated: 2026-04-08T17:18:08.882Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4031 |
vulnerable | 2026-06-08 05:51:36.585079 |
Simple:Press <= 6.8 - Authenticated (Admin+) Path Traversal to Arbitrary File Modification
LOW (3.8)
The Simple:Press plugin for WordPress is vulnerable to arbitrary file modifications in versions up to, and including, 6.8 via the 'file' parameter which does not properly restrict files to be edited in the context of the plugin. This makes it possible with attackers, with high-level permissions such as an administrator, to supply paths to arbitrary files on the server that can be modified outside of the intended scope of the plugin.
Published: 2022-11-29T20:15:59.914Z
Updated: 2026-04-08T16:40:49.935Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4030 |
vulnerable | 2026-06-08 05:51:36.584345 |
Simple:Press <= 6.8 - Authenticated (Subscriber+) Path Traversal to Arbitrary File Deletion
HIGH (8.1)
The Simple:Press plugin for WordPress is vulnerable to Path Traversal in versions up to, and including, 6.8 via the 'file' parameter which can be manipulated during user avatar deletion. This makes it possible with attackers, with minimal permissions such as a subscriber, to supply paths to arbitrary files on the server that will subsequently be deleted. This can be used to delete the wp-config.php file that can allow an attacker to configure the site and achieve remote code execution.
Published: 2022-11-29T20:13:25.260Z
Updated: 2026-04-08T16:49:11.427Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4029 |
vulnerable | 2026-06-08 05:51:36.583685 |
Simple:Press <= 6.8 - Reflected Cross-Site Scripting via Cookie Value
MEDIUM (4.7)
The Simple:Press plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'sforum_[md5 hash of the WordPress URL]' cookie value in versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This would be highly complex to exploit as it would require the attacker to set the cookie a cookie for the targeted user.
Published: 2022-11-29T20:10:24.741Z
Updated: 2026-04-08T16:53:32.739Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4028 |
vulnerable | 2026-06-08 05:51:36.583171 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4027 |
vulnerable | 2026-06-08 05:51:36.580775 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-36706 |
vulnerable | 2026-06-08 05:25:49.413435 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.