Approved changes feed: RSS · Atom

cpe:2.3:a:wordpress_popular_posts_project:wordpress_popular_posts:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorWordpress Popular Posts Project (dff79d7b-24fb-50ec-83da-b2e6d9a7d277)
ProductWordpress Popular Posts (c10dae80-07cb-5ad2-a783-c5c81f29c472)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-45607 vulnerable 2026-06-08 06:12:42.909047 WordPress WordPress Popular Posts Plugin <= 6.3.2 is vulnerable to Cross Site Scripting (XSS)
MEDIUM (6.5)
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Hector Cabrera WordPress Popular Posts plugin <= 6.3.2 versions.
Published: 2023-10-18T13:13:17.797Z
Updated: 2026-04-28T16:08:43.330Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-43468 vulnerable 2026-06-08 05:49:32.034752 Details available
External initialization of trusted variables or data stores vulnerability exists in WordPress Popular Posts 6.0.5 and earlier, therefore the vulnerable product accepts untrusted external inputs to update certain internal variables. As a result, the number of views for an article may be manipulated through a crafted input.
Published: 2022-12-07T00:00:00.000Z
Updated: 2025-04-23T18:15:21.717Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-42362 vulnerable 2026-06-08 05:35:22.217489 WordPress Popular Posts <= 5.3.2 Authenticated Arbitrary File Upload
HIGH (8.8)
The WordPress Popular Posts WordPress plugin is vulnerable to arbitrary file uploads due to insufficient input file type validation found in the ~/src/Image.php file which makes it possible for attackers with contributor level access and above to upload malicious files that can be used to obtain remote code execution, in versions up to and including 5.3.2.
Published: 2021-11-17T17:44:23.922Z
Updated: 2024-09-16T18:45:18.029Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-36872 vulnerable 2026-06-08 05:32:52.646838 WordPress Popular Posts plugin <= 5.3.3 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability
MEDIUM (5.5)
Authenticated Persistent Cross-Site Scripting (XSS) vulnerability in WordPress Popular Posts plugin (versions <= 5.3.3). Vulnerable at &widget-wpp[2][post_type].
Published: 2021-09-23T15:00:55.804Z
Updated: 2026-04-28T16:07:35.841Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-20746 vulnerable 2026-06-08 05:29:10.507557 Details available
Cross-site scripting vulnerability in WordPress Popular Posts 5.3.2 and earlier allows a remote authenticated attacker to inject an arbitrary script via unspecified vectors.
Published: 2021-06-28T00:50:35.000Z
Updated: 2024-08-03T17:53:21.923Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.