Approved changes feed: RSS · Atom

cpe:2.3:a:extendify:editorskit:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorExtendify (b123b7f9-9cc8-5e75-943f-18e2d2722e86)
ProductEditorskit (0cde7fe5-14a3-53fa-9293-234f9ac2bc42)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-6635 vulnerable 2026-06-08 06:21:55.177848 EditorsKit <= 1.40.3 - Authenticated (Administrator+) Arbitrary File Upload
HIGH (7.2)
The EditorsKit plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation on the 'import_styles' function in versions up to, and including, 1.40.3. This makes it possible for authenticated attackers with administrator-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Published: 2024-02-05T21:21:42.520Z
Updated: 2026-04-08T16:49:31.407Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24546 vulnerable 2026-06-08 05:30:04.558812 EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution
The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code
Published: 2021-10-11T10:45:29.000Z
Updated: 2024-08-03T19:35:20.035Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.