Wpschoolpress
Approved changes feed: RSS · Atom
cpe:2.3:a:igexsolutions:wpschoolpress:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Igexsolutions (7b30ee82-e785-5c20-b109-1677962e289a) |
|---|---|
| Product | Wpschoolpress (e0d1e216-1c42-52b2-bbb9-e3ddaf6365dc) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-1670 |
vulnerable | 2026-06-08 07:08:37.554605 |
School Management System – WPSchoolPress <= 2.2.16 - Authenticated (Parent+) SQL Injection
MEDIUM (6.5)
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to SQL Injection via the 'cid' parameter in all versions up to, and including, 2.2.16 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Custom-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-03-15T03:23:25.455Z
Updated: 2026-04-08T17:32:55.403Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-1669 |
vulnerable | 2026-06-08 07:08:37.554089 |
School Management System – WPSchoolPress <= 2.2.17 - Authenticated (Teacher+) SQL Injection
MEDIUM (6.5)
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to SQL Injection via the 'addNotify' action in all versions up to, and including, 2.2.17 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with teacher-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-03-15T03:23:24.332Z
Updated: 2026-04-08T17:17:37.770Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-1668 |
vulnerable | 2026-06-08 07:08:37.553652 |
School Management System – WPSchoolPress <= 2.2.16 - Missing Authorization to Arbitrary User Deletion
MEDIUM (4.3)
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to arbitrary user deletion due to a missing capability check on the wpsp_DeleteUser() function in all versions up to, and including, 2.2.16. This makes it possible for authenticated attackers, with teacher-level access and above, to delete arbitrary user accounts.
Published: 2025-03-15T03:23:25.806Z
Updated: 2026-04-08T17:34:56.872Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-1667 |
vulnerable | 2026-06-08 07:08:37.553000 |
School Management System – WPSchoolPress <= 2.2.16 - Missing Authorization to Privilege Escalation via Account Takeover
HIGH (8.8)
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to Privilege Escalation due to a missing capability check on the wpsp_UpdateTeacher() function in all versions up to, and including, 2.2.16. This makes it possible for authenticated attackers, with teacher-level access and above, to update arbitrary user details including email which makes it possible to request a password reset and access arbitrary user accounts, including administrators.
Published: 2025-03-15T03:23:25.085Z
Updated: 2026-04-08T17:29:50.536Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-9637 |
vulnerable | 2026-06-08 07:00:28.363053 |
School Management System – WPSchoolPress <= 2.2.10 - Insecure Direct Object Reference to Authenticated (Teacher+) Account Takeover/Privilege Escalation
HIGH (8.8)
The School Management System – WPSchoolPress plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 2.2.10. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with teacher-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Published: 2024-10-26T08:36:00.481Z
Updated: 2026-04-08T16:48:34.081Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-12332 |
vulnerable | 2026-06-08 06:23:51.726666 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-4776 |
vulnerable | 2026-06-08 06:16:14.545483 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24664 |
vulnerable | 2026-06-08 05:30:38.966862 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24575 |
vulnerable | 2026-06-08 05:30:38.795213 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.