Email Encoder
Approved changes feed: RSS · Atom
cpe:2.3:a:wp-webhooks:email_encoder:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Wp Webhooks (75f45c5a-0207-5d72-be8c-1dd543a9b2bf) |
|---|---|
| Product | Email Encoder (43c20ce8-2dcc-5296-a207-c7ac634bfcb3) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-4483 |
vulnerable | 2026-06-08 06:50:17.845128 |
Email Encoder < 2.2.2 - Admin+ Stored XSS
The Email Encoder WordPress plugin before 2.2.2 does not escape the WP_Email_Encoder_Bundle_options[protection_text] parameter before outputting it back in an attribute in an admin page, leading to a Stored Cross-Site Scripting
Published: 2024-07-29T06:00:01.115Z
Updated: 2024-08-01T20:40:47.409Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-4599 |
vulnerable | 2026-06-08 06:16:13.535721 |
Email Encoder <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
MEDIUM (6.4)
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Published: 2023-08-30T01:45:37.536Z
Updated: 2026-04-08T17:30:43.117Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-24599 |
vulnerable | 2026-06-08 05:30:38.840544 |
Email Encoder < 2.1.2 - Reflected Cross Site Scripting
The Email Encoder – Protect Email Addresses WordPress plugin before 2.1.2 has an endpoint that requires no authentication and will render a user supplied value in the HTML response without escaping or sanitizing the data.
Published: 2021-09-06T11:09:31.000Z
Updated: 2024-08-03T19:35:20.312Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.