Approved changes feed: RSS · Atom

cpe:2.3:a:benbodhi:svg_support:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorBenbodhi (6d89218c-c001-5d7f-9844-c5bbe05f13c2)
ProductSvg Support (0b3e099f-c54c-565f-b6b2-b742cf086282)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-10222 vulnerable 2026-06-08 06:22:03.803249 SVG Support <= 2.5.10 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
MEDIUM (6.4)
The SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 2.5.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file. By default, this can only be exploited by administrators, but the ability to upload SVG files can be extended to authors.
Published: 2025-02-21T13:41:28.666Z
Updated: 2026-04-08T16:54:34.119Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-4022 vulnerable 2026-06-08 05:51:36.573048 Details available
MEDIUM (6.4)
The SVG Support plugin for WordPress defaults to insecure settings in version 2.5 and 2.5.1. SVG files containing malicious javascript are not sanitized. While version 2.5 adds the ability to sanitize image as they are uploaded, the plugin defaults to disable sanitization and does not restrict SVG upload to only administrators. This allows authenticated attackers, with author-level privileges and higher, to upload malicious SVG files that can be embedded in posts and pages by higher privileged users. Additionally, the embedded JavaScript is also triggered on visiting the image URL, which allows an attacker to execute malicious code in browsers visiting that URL.
Published: 2022-11-16T13:23:44.784Z
Updated: 2025-02-07T20:32:49.213Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-1755 vulnerable 2026-06-08 05:39:13.862340 SVG Support < 2.5 - Author+ Stored Cross-Site Scripting
The SVG Support WordPress plugin before 2.5 does not properly handle SVG added via an URL, which could allow users with a role as low as author to perform Cross-Site Scripting attacks
Published: 2022-09-26T12:35:31.000Z
Updated: 2025-05-21T19:21:54.712Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24686 vulnerable 2026-06-08 05:30:39.009982 SVG Support < 2.3.20 - Admin+ Stored Cross-Site Scripting
The SVG Support WordPress plugin before 2.3.20 does not escape the "CSS Class to target" setting before outputting it in an attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Published: 2022-02-01T12:21:19.000Z
Updated: 2024-08-03T19:42:16.115Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.