Approved changes feed: RSS · Atom

cpe:2.3:a:loco_translate_project:loco_translate:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorLoco Translate Project (ee97e76b-da1c-5e0e-9b95-f61a2db881f3)
ProductLoco Translate (300f3c89-e515-5b5c-98d8-0fd54cbe196a)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-0765 vulnerable 2026-06-08 05:39:10.780833 Loco Translate < 2.6.1 - Authenticated Stored Cross-Site Scripting
The Loco Translate WordPress plugin before 2.6.1 does not properly remove inline events from elements in the source translation strings before outputting them in the editor in the plugin admin panel, allowing any user with access to the plugin (Translator and Administrator by default) to add arbitrary javascript payloads to the source strings leading to a stored cross-site scripting (XSS) vulnerability.
Published: 2022-04-18T17:10:35.000Z
Updated: 2024-08-02T23:40:03.770Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24721 vulnerable 2026-06-08 05:30:39.079655 Loco Translate < 2.5.4 - Authenticated PHP Code Injection
The Loco Translate WordPress plugin before 2.5.4 mishandles data inputs which get saved to a file, which can be renamed to an extension ending in .php, resulting in authenticated "translator" users being able to inject PHP code into files ending with .php in web accessible locations.
Published: 2021-11-08T17:35:14.000Z
Updated: 2024-08-03T19:42:16.687Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.