Approved changes feed: RSS · Atom

cpe:2.3:a:variation_swatches_for_woocommerce_project:variation_swatches_for_woocommerce:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorVariation Swatches For Woocommerce Project (4de51265-ce14-5ecb-8237-2876b7959a3b)
ProductVariation Swatches For Woocommerce (0882cd24-2d01-5ccf-ae23-d0dd1a8685a3)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-13511 vulnerable 2026-06-08 06:25:37.843384 Variation Swatches for WooCommerce 1.0.8 - 1.3.2 - Cross-Site Request Forgery to Plugin Settings Reset
MEDIUM (4.3)
The Variation Swatches for WooCommerce plugin, in all versions starting at 1.0.8 up until 1.3.2, contains a vulnerability due to improper nonce verification in its settings reset functionality. The issue exists in the settings_init() function, which processes a reset action based on specific query parameters in the URL. The related delete_settings() function performs a faulty nonce validation check, making the reset operation insecure and susceptible to unauthorized access.
Published: 2025-01-23T09:21:08.768Z
Updated: 2025-01-23T14:45:05.787Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-37975 vulnerable 2026-06-08 06:08:16.614077 WordPress Variation Swatches for WooCommerce Plugin <= 2.3.7 is vulnerable to Cross Site Scripting (XSS)
HIGH (7.1)
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in RadiusTheme Variation Swatches for WooCommerce plugin <= 2.3.7 versions.
Published: 2023-07-27T14:25:32.576Z
Updated: 2026-04-28T16:08:32.946Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-42367 vulnerable 2026-06-08 05:35:22.226553 Variation Swatches for WooCommerce <= 2.1.1 Authenticated Stored Cross-Site Scripting
MEDIUM (6.4)
The Variation Swatches for WooCommerce WordPress plugin is vulnerable to Stored Cross-Site Scripting via several parameters found in the ~/includes/class-menu-page.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 2.1.1. Due to missing authorization checks on the tawcvs_save_settings function, low-level authenticated users such as subscribers can exploit this vulnerability.
Published: 2021-12-14T15:50:10.177Z
Updated: 2025-02-13T20:47:20.144Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.