Approved changes feed: RSS · Atom

cpe:2.3:a:wpeasypay:wp_easypay:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorWpeasypay (2e2b0959-64a2-562c-9f7a-546147982d3d)
ProductWp Easypay (2de3bdc9-7f69-58b3-add2-db9eb4adc10d)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-5861 vulnerable 2026-06-08 06:56:17.640321 WP Easy Pay (Free) <= 4.2.3 - Missing Authorization to Unauthenticated Service Disconnection
MEDIUM (5.3)
The WP EasyPay – Square for WordPress plugin for WordPress is vulnerable to unauthorized modification of datadue to a missing capability check on the wpep_square_disconnect() function in all versions up to, and including, 4.2.3. This makes it possible for unauthenticated attackers to disconnect square.
Published: 2024-07-24T03:17:16.440Z
Updated: 2026-04-08T16:49:20.972Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-1465 vulnerable 2026-06-08 05:52:35.953888 WP EasyPay < 4.1 - Reflected Cross-Site Scripting
The WP EasyPay WordPress plugin before 4.1 does not escape some generated URLs before outputting them back in pages, leading to Reflected Cross-Site Scripting issues which could be used against high privilege users such as admin
Published: 2023-08-16T11:03:27.810Z
Updated: 2025-05-05T16:07:02.998Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-47177 vulnerable 2026-06-08 05:50:39.955858 WordPress WP EasyPay Plugin <= 4.1 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (4.3)
Cross-Site Request Forgery (CSRF) vulnerability in WP Easy Pay WP EasyPay – Square for WordPress plugin <= 4.1 versions.
Published: 2023-05-25T09:51:39.536Z
Updated: 2026-04-28T16:07:57.081Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-4411 vulnerable 2026-06-08 05:38:09.370898 WP EasyPay – Square for WordPress <= 3.2.0 - Cross-Site Request Forgery Bypass
MEDIUM (4.3)
The WP EasyPay – Square for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.2.0. This is due to missing or incorrect nonce validation on the wpep_download_transaction_in_excel() function. This makes it possible for unauthenticated attackers to trigger a transactions download via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2023-07-12T03:40:42.949Z
Updated: 2026-04-08T17:12:33.173Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.