Approved changes feed: RSS · Atom

cpe:2.3:a:armemberplugin:armember:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorArmemberplugin (b820d35b-cfce-55b5-896e-0fc31ad916ce)
ProductArmember (b3b7601b-7a6d-5f46-9a2f-6cfe8ba1dad7)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-32948 vulnerable 2026-06-08 06:37:24.758748 WordPress ARMember – Membership Plugin plugin <= 4.0.28 - Broken Access Control vulnerability
CRITICAL (9.1)
Missing Authorization vulnerability in Repute Infosystems ARMember.This issue affects ARMember: from n/a through 4.0.28.
Published: 2024-04-24T07:03:17.452Z
Updated: 2026-04-28T16:09:41.971Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-47837 vulnerable 2026-06-08 06:14:25.814517 WordPress ARMember plugin <= 4.0.10 - Membership Plan Bypass vulnerability
HIGH (8.3)
Improper Privilege Management vulnerability in Repute Infosystems ARMember allows Privilege Escalation.This issue affects ARMember: from n/a through 4.0.10.
Published: 2024-06-04T10:10:14.075Z
Updated: 2026-04-28T16:08:52.846Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-3996 vulnerable 2026-06-08 06:09:40.983727 ARMember Lite - Membership Plugin <= 4.0.16 - Authenticated (Administrator+) Stored Cross-Site Scripting
MEDIUM (4.4)
The ARMember Lite - Membership Plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 4.0.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Published: 2023-10-20T07:29:30.155Z
Updated: 2026-04-08T17:19:45.946Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-3011 vulnerable 2026-06-08 06:09:38.300727 ARMember <= 4.0.5 - Cross-Site Request Forgery
MEDIUM (6.5)
The ARMember plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.0.5. This is due to missing or incorrect nonce validation on the arm_check_user_cap function. This makes it possible for unauthenticated attackers to perform multiple unauthorized actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2023-07-12T04:38:44.334Z
Updated: 2026-04-08T16:49:01.557Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-1903 vulnerable 2026-06-08 05:39:14.203277 ARMember < 3.4.8 - Unauthenticated Admin Account Takeover
The ARMember WordPress plugin before 3.4.8 is vulnerable to account takeover (even the administrator) due to missing nonce and authorization checks in an AJAX action available to unauthenticated users, allowing them to change the password of arbitrary users by knowing their username
Published: 2022-06-27T08:58:19.000Z
Updated: 2024-08-03T00:17:00.971Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.