Approved changes feed: RSS · Atom

cpe:2.3:a:banner_cycler_project:banner_cycler:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorBanner Cycler Project (52f16de2-c2ef-5ebd-869c-396f6af0bdf2)
ProductBanner Cycler (e0ef5d98-de7b-5996-a5a5-72058e18a730)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-2233 vulnerable 2026-06-08 05:43:35.082343 Banner Cycler <= 1.4 - Cross-Site Request Forgery to Cross-Site Scripting
HIGH (8.8)
The Banner Cycler plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.4. This is due to missing nonce protection on the pabc_admin_slides_postback() function found in the ~/admin/admin.php file. This makes it possible for unauthenticated attackers to inject malicious web scripts into the page, granted they can trick a site’s administrator into performing an action such as clicking on a link
Published: 2022-09-06T17:18:55.000Z
Updated: 2026-04-08T16:59:15.795Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.