Approved changes feed: RSS · Atom

cpe:2.3:a:standalonetech:terawallet:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorStandalonetech (4aca2647-34ec-522f-86df-24240e56715f)
ProductTerawallet (5e8baee5-632e-5eec-93db-1300ee2ce007)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-7747 vulnerable 2026-06-08 06:58:23.358350 Wallet for WooCommerce <= 1.5.6 - Authenticated (Subscriber+) Incorrect Conversion between Numeric Types
MEDIUM (6.5)
The Wallet for WooCommerce plugin for WordPress is vulnerable to incorrect conversion between numeric types in all versions up to, and including, 1.5.6. This is due to a numerical logic flaw when transferring funds to another user. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create funds during a transfer and distribute these funds to any number of other users or their own account, rendering products free. Attackers could also request to withdraw funds if the Wallet Withdrawal extension is used and the request is approved by an administrator.
Published: 2024-11-28T12:54:10.225Z
Updated: 2026-04-08T17:34:59.194Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-6353 vulnerable 2026-06-08 06:58:18.736011 Wallet for WooCommerce <= 1.5.4 - Authenticated (Subscriber+) SQL Injection via 'search[value]'
HIGH (8.8)
The Wallet for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the 'search[value]' parameter in all versions up to, and including, 1.5.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2024-07-12T08:32:13.089Z
Updated: 2026-04-08T17:33:49.569Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-32584 vulnerable 2026-06-08 06:37:23.260162 WordPress TeraWallet plugin <= 1.5.0 - Cross Site Scripting (XSS) vulnerability
MEDIUM (5.9)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StandaloneTech TeraWallet – For WooCommerce allows Stored XSS.This issue affects TeraWallet – For WooCommerce: from n/a through 1.5.0.
Published: 2024-04-18T09:14:24.718Z
Updated: 2026-04-28T16:09:37.763Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-1690 vulnerable 2026-06-08 06:27:14.104675 TeraWallet – Best WooCommerce Wallet System With Cashback Rewards, Partial Payment, Wallet Refunds <= 1.4.10 - Missing Authorization to Authenticated (Subscriber+) User Email Export
MEDIUM (4.3)
The TeraWallet – Best WooCommerce Wallet System With Cashback Rewards, Partial Payment, Wallet Refunds plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the terawallet_export_user_search() function in all versions up to, and including, 1.4.10. This makes it possible for authenticated attackers, with subscriber-level access and above, to export a list of registered users and their emails.
Published: 2024-03-13T15:26:34.506Z
Updated: 2026-04-08T16:37:43.638Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-40198 vulnerable 2026-06-08 05:48:24.160175 WordPress TeraWallet – For WooCommerce Plugin <= 1.3.24 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (4.3)
Cross-Site Request Forgery (CSRF) vulnerability in StandaloneTech TeraWallet – For WooCommerce plugin <= 1.3.24 leading to plugin settings change.
Published: 2023-03-01T13:11:00.991Z
Updated: 2026-04-28T16:07:47.665Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-3995 vulnerable 2026-06-08 05:48:22.786727 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-36401 vulnerable 2026-06-08 05:46:07.346614 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.