Approved changes feed: RSS · Atom
cpe:2.3:a:bricks_builder:bricks:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Bricks Builder (caf2c801-cb0f-5cb7-9199-674cb5babf32) |
|---|---|
| Product | Bricks (91928ea0-d8e1-5b4a-aa9d-2b9b0c569bc1) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-6495 |
vulnerable | 2026-06-08 07:43:15.164975 |
Bricks Builder <= 1.12.4 - Unauthenticated SQL Injection via `p` Parameter
HIGH (7.5)
The Bricks theme for WordPress is vulnerable to blind SQL Injection via the ‘p’ parameter in all versions up to, and including, 1.12.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-07-29T04:23:44.765Z
Updated: 2026-04-08T16:55:14.110Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2297 |
vulnerable | 2026-06-08 06:33:30.789380 |
Bricksbuilder <= 1.9.6.1 - Authenticated (Contributor+) Privilege Escalation via create_autosave
HIGH (7.1)
The Bricks theme for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.9.6.1. This is due to insufficient validation checks placed on the create_autosave AJAX function. This makes it possible for authenticated attackers, with contributor-level access and above, to execute arbitrary PHP code with elevated (administrator-level) privileges. NOTE: Successful exploitation requires (1) the Bricks Builder to be enabled for posts (2) Builder access to be enabled for contributor-level users, and (3) "Code Execution" to be enabled for administrator-level users within the theme's settings.
Published: 2025-02-27T05:23:05.572Z
Updated: 2026-04-08T17:23:24.076Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-3410 |
vulnerable | 2026-06-08 06:09:39.504508 |
Bricks <= 1.10.1 - Authenticated (Bricks Page Builder Access+) Stored Cross-Site Scripting
MEDIUM (5.4)
The Bricks theme for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘customTag' attribute in versions up to, and including, 1.10.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with access to the Bricks Builder (admin-only by default), to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This becomes more of an issue when Bricks Builder access is granted to lower-privileged users.
Published: 2024-09-14T08:37:20.494Z
Updated: 2026-04-08T17:18:13.335Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-3409 |
vulnerable | 2026-06-08 06:09:39.503926 |
Bricks <= 1.8.1 - Cross-Site Request Forgery via reset_settings
MEDIUM (5.4)
The Bricks theme for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.1. This is due to missing or incorrect nonce validation on the 'reset_settings' function. This makes it possible for unauthenticated attackers to reset the theme's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2024-08-17T08:37:23.103Z
Updated: 2026-04-08T16:37:12.156Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-3408 |
vulnerable | 2026-06-08 06:09:39.502932 |
Bricks <= 1.8.1 - Cross-Site Request Forgery via save_settings
MEDIUM (4.3)
The Bricks theme for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.8.1. This is due to missing or incorrect nonce validation on the 'save_settings' function. This makes it possible for unauthenticated attackers to modify the theme's settings, including enabling a setting which allows lower-privileged users such as contributors to perform code execution, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2024-08-17T08:37:24.796Z
Updated: 2026-04-08T17:26:10.058Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-3401 |
vulnerable | 2026-06-08 05:48:20.842064 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-3400 |
vulnerable | 2026-06-08 05:48:20.840896 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.