Approved changes feed: RSS · Atom

cpe:2.3:a:simplepress:simple:press_–_wordpress_forum_plugin:*:*:*:*:*:*:*:*

part: a version: press_–_wordpress_forum_plugin update: *

VendorSimplepress (ee70f5c3-af8c-5436-8588-5442826a4ece)
ProductSimple (5fa65922-e905-5387-b666-645bd88823ba)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-4030 vulnerable 2026-06-08 05:51:36.584482 Simple:Press <= 6.8 - Authenticated (Subscriber+) Path Traversal to Arbitrary File Deletion
HIGH (8.1)
The Simple:Press plugin for WordPress is vulnerable to Path Traversal in versions up to, and including, 6.8 via the 'file' parameter which can be manipulated during user avatar deletion. This makes it possible with attackers, with minimal permissions such as a subscriber, to supply paths to arbitrary files on the server that will subsequently be deleted. This can be used to delete the wp-config.php file that can allow an attacker to configure the site and achieve remote code execution.
Published: 2022-11-29T20:13:25.260Z
Updated: 2026-04-08T16:49:11.427Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-4029 vulnerable 2026-06-08 05:51:36.583752 Simple:Press <= 6.8 - Reflected Cross-Site Scripting via Cookie Value
MEDIUM (4.7)
The Simple:Press plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'sforum_[md5 hash of the WordPress URL]' cookie value in versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This would be highly complex to exploit as it would require the attacker to set the cookie a cookie for the targeted user.
Published: 2022-11-29T20:10:24.741Z
Updated: 2026-04-08T16:53:32.739Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-4027 vulnerable 2026-06-08 05:51:36.582693 Simple:Press <= 6.8 - Unauthenticated Stored Cross-Site Scripting via Forum Replies
HIGH (7.2)
The Simple:Press plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'postitem' parameter manipulated during a forum response in versions up to, and including, 6.8 due to insufficient input sanitization and output escaping that makes injecting object and embed tags possible. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages when responding to forum threads that will execute whenever a user accesses an injected page.
Published: 2022-11-29T20:06:05.069Z
Updated: 2026-04-08T16:49:55.731Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.