Password Protect Wordpress
Approved changes feed: RSS · Atom
cpe:2.3:a:passwordprotectwp:password_protect_wordpress:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Passwordprotectwp (9f28e427-0edf-5b03-a24d-03551a054654) |
|---|---|
| Product | Password Protect Wordpress (6d587810-e2eb-5d80-8c3f-5ceb3daa9142) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-5998 |
vulnerable | 2026-06-08 07:37:26.232342 |
PPWP < 1.9.11 - Subscriber+ Access Bypass via REST API
The PPWP – Password Protect Pages WordPress plugin before version 1.9.11 allows to put the site content behind a password authorization, however users with subscriber or greater roles can view content via the REST API.
Published: 2025-08-14T08:48:54.861Z
Updated: 2025-08-14T14:49:42.824Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0620 |
vulnerable | 2026-06-08 06:22:01.509424 |
PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass
MEDIUM (5.3)
The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.9 via API. This makes it possible for unauthenticated attackers to obtain post titles, IDs, slugs as well as other information including for password-protected posts.
Published: 2024-02-20T18:56:27.217Z
Updated: 2026-04-08T16:48:36.172Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-4626 |
vulnerable | 2026-06-08 05:52:00.039432 |
PPWP – WordPress Password Protect Page < 1.8.6 - Contributor+ Stored XSS in Shortcode
The PPWP WordPress plugin before 1.8.6 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Published: 2023-02-06T19:59:50.239Z
Updated: 2025-03-25T17:37:26.363Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.