Approved changes feed: RSS · Atom
cpe:2.3:a:avo-hq:avo:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Avo Hq (e2945987-a4bb-59da-a175-2ceb6c755b33) |
|---|---|
| Product | Avo (5dbe6146-3883-5e68-b427-0d07ca60c6e0) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-53769 |
vulnerable | 2026-09-16 04:33:52.934427 |
Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy
MEDIUM (6.5)
Avo is a framework to create admin panels for Ruby on Rails apps. From version 2.28.0 to before version 3.32.0, Avo's direct attachment upload endpoint lacks server-side upload authorization and bypasses the documented field-level upload policy methods such as upload_{FIELD_ID}?. An authenticated Avo user who can reach the Avo attachment upload endpoint can replace or add attachment content, including binary content, filename, and content-type metadata, on a resolved record even when both update? and upload_<field>? policies deny the operation. This primarily affects multi-role Avo Pro/Advanced-style deployments where non-administrator or restricted operator users can reach Avo and per-record or per-field operations are expected to be enforced by policies. This issue has been patched in version 3.32.0.
Published: 2026-09-04T20:02:01.456Z
Updated: 2026-09-09T15:57:27.231Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-42205 |
vulnerable | 2026-06-08 08:03:16.021458 |
Avo: Broken Access Control: Unauthorized Execution of Arbitrary Action Classes Across Resources
HIGH (8.8)
Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.31.2, a broken access control vulnerability was identified in the ActionsController of the Avo framework. Due to insecure action lookup logic, an authenticated user can execute any Action class (descendants of Avo::BaseAction) on any resource, even if the action is not registered for that specific resource. This leads to Privilege Escalation and unauthorized data manipulation across the entire application. This issue has been patched in version 3.31.2.
Published: 2026-05-08T21:26:44.743Z
Updated: 2026-05-12T18:31:59.049Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-33209 |
vulnerable | 2026-06-08 07:59:09.353079 |
Avo has a XSS vulnerability on `return_to` param
Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.30.3, a reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface. An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button. This issue has been patched in version 3.30.3.
Published: 2026-03-20T22:39:19.422Z
Updated: 2026-03-24T18:07:25.007Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-22411 |
vulnerable | 2026-06-08 06:29:34.893754 |
Cross site scripting in Action messages on Avo
MEDIUM (6.5)
Avo is a framework to create admin panels for Ruby on Rails apps. In Avo 3 pre12, any HTML inside text that is passed to `error` or `succeed` in an `Avo::BaseAction` subclass will be rendered directly without sanitization in the toast/notification that appears in the UI on Action completion. A malicious user could exploit this vulnerability to trigger a cross site scripting attack on an unsuspecting user. This issue has been addressed in the 3.3.0 and 2.47.0 releases of Avo. Users are advised to upgrade.
Published: 2024-01-16T21:57:44.824Z
Updated: 2025-06-02T15:07:11.491Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-22191 |
vulnerable | 2026-06-08 06:29:34.065433 |
Stored cross-site scripting (XSS) in `key_value` field in Avo
HIGH (7.3)
Avo is a framework to create admin panels for Ruby on Rails apps. A stored cross-site scripting (XSS) vulnerability was found in the key_value field of Avo v3.2.3 and v2.46.0. This vulnerability could allow an attacker to execute arbitrary JavaScript code in the victim's browser. The value of the key_value is inserted directly into the HTML code. In the current version of Avo (possibly also older versions), the value is not properly sanitized before it is inserted into the HTML code. This vulnerability could be used to steal sensitive information from victims that could be used to hijack victims' accounts or redirect them to malicious websites. Avo 3.2.4 and 2.47.0 include a fix for this issue. Users are advised to upgrade.
Published: 2024-01-16T21:57:37.268Z
Updated: 2024-10-21T12:03:51.403Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-34103 |
vulnerable | 2026-06-08 06:06:24.511941 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-34102 |
vulnerable | 2026-06-08 06:06:24.510352 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.