Save As Pdf Plugin By Pdfcrowd
Approved changes feed: RSS · Atom
cpe:2.3:a:pdfcrowd:save_as_pdf_plugin_by_pdfcrowd:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Pdfcrowd (7f085363-67df-5d7a-98f9-512b3784ef2e) |
|---|---|
| Product | Save As Pdf Plugin By Pdfcrowd (75a7e236-d3a7-52d9-8921-2e59c2eb8f6b) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-92807 |
vulnerable | 2026-10-13 12:28:53.449234 |
Save as PDF Plugin by PDFCrowd <= 4.6.1 - Authenticated (Contributor+) Arbitrary Function Invocation / Code Injection via 'pdf_created_callback' Shortcode Attribute
HIGH (8.8)
The Save as PDF Plugin by PDFCrowd plugin for WordPress is vulnerable to Arbitrary Function Invocation in all versions up to, and including, 4.6.1 via the `pdf_created_callback` shortcode attribute. The `eval_shortcode()` function copies any non-`button_`/non-`email_` shortcode attribute verbatim into a custom options array without sanitization, allowlist enforcement, or capability checks, and `create_button()` AES-encrypts that array — including the attacker-supplied callback value — and embeds the resulting blob in the rendered button HTML; when the blob is later POSTed to the unauthenticated `wp_ajax_nopriv_save_as_pdf_pdfcrowd` endpoint, `save_as_pdf_pdfcrowd()` decrypts it and invokes `$options['pdf_created_callback']` as a PHP callable at line 1722 with no `is_callable()` guard, no allowlist, and no capability check. This makes it possible for authenticated attackers, with Contributor-level access and above, to invoke arbitrary PHP functions or static class methods with plugin option data as the sole argument, enabling disclosure of the site's stored PDFCrowd API key and username or further server-side abuse. Note that the encryption boundary does not mitigate this vector because the server itself encrypts the attacker-chosen callback during shortcode rendering, supplying any authenticated Contributor with a cryptographically valid blob that any unauthenticated visitor can subsequently replay to trigger invocation.
Published: 2026-09-19T02:27:13.066Z
Updated: 2026-09-19T14:01:25.572Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-0862 |
vulnerable | 2026-06-08 07:47:13.387255 |
Save as PDF Plugin by PDFCrowd <= 4.5.5 - Reflected Cross-Site Scripting via options
MEDIUM (6.1)
The Save as PDF Plugin by PDFCrowd plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘options’ parameter in all versions up to, and including, 4.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. NOTE: Successful exploitation of this vulnerability requires that the PDFCrowd API key is blank (also known as "demo mode", which is the default configuration when the plugin is installed) or known.
Published: 2026-01-24T15:34:06.548Z
Updated: 2026-04-08T17:01:05.994Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-37549 |
vulnerable | 2026-06-08 06:39:47.905455 |
WordPress Save as PDF plugin by Pdfcrowd plugin <= 4.0.0 - Cross Site Scripting (XSS) vulnerability
MEDIUM (5.9)
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Pdfcrowd Save as PDF plugin by Pdfcrowd allows Stored XSS.This issue affects Save as PDF plugin by Pdfcrowd: from n/a through 4.0.0.
Published: 2024-07-21T07:00:24.302Z
Updated: 2026-04-28T16:10:01.036Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-35649 |
vulnerable | 2026-06-08 06:39:42.230022 |
WordPress Save as PDF Plugin by Pdfcrowd plugin <= 3.2.3 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Pdfcrowd Save as PDF plugin by Pdfcrowd allows Stored XSS.This issue affects Save as PDF plugin by Pdfcrowd: from n/a through 3.2.3.
Published: 2024-06-04T14:17:06.757Z
Updated: 2026-04-28T16:09:52.264Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-33684 |
vulnerable | 2026-06-08 06:37:31.979631 |
WordPress Save as PDF plugin by Pdfcrowd plugin <= 3.2.0 - Broken Access Control to Stored XSS vulnerability
MEDIUM (6.5)
Missing Authorization vulnerability in Pdfcrowd Save as PDF plugin by Pdfcrowd allows Stored XSS.This issue affects Save as PDF plugin by Pdfcrowd: from n/a through 3.2.0.
Published: 2024-04-29T08:17:43.039Z
Updated: 2026-04-28T16:09:45.191Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-31930 |
vulnerable | 2026-06-08 06:35:32.428671 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-10891 |
vulnerable | 2026-06-08 06:23:47.922398 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-40668 |
vulnerable | 2026-06-08 06:11:04.182530 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.