Approved changes feed: RSS · Atom

cpe:2.3:a:aruba.it:aruba_hispeed_cache:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAruba.It (389b02a5-dfed-5d44-bc3c-34127967a5ff)
ProductAruba Hispeed Cache (2dfa6aa8-41d5-543e-ae60-8c6b3eefff63)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-23694 vulnerable 2026-06-08 07:51:16.017506 Aruba HiSpeed Cache < 3.0.5 CSRF in Multiple Administrative AJAX Actions
Aruba HiSpeed Cache (aruba-hispeed-cache) WordPress plugin versions prior to 3.0.5 contain a cross-site request forgery (CSRF) vulnerability affecting multiple administrative AJAX actions. The handlers for ahsc_reset_options, ahsc_debug_status, and ahsc_enable_purge perform authentication and capability checks but do not verify a WordPress nonce for state-changing requests. An attacker can induce a logged-in administrator to visit a malicious webpage that submits forged requests to admin-ajax.php, resulting in unauthorized resetting of plugin settings, toggling of the WordPress WP_DEBUG configuration, or modification of cache purging behavior without the administrator’s intent.
Published: 2026-02-23T20:29:20.354Z
Updated: 2026-03-05T01:30:20.977Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-43119 vulnerable 2026-06-08 06:45:49.618611 WordPress Aruba HiSpeed Cache plugin <= 2.0.12 - Broken Access Control vulnerability
MEDIUM (4.3)
Missing Authorization vulnerability in Aruba.It Aruba HiSpeed Cache allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Aruba HiSpeed Cache: from n/a through 2.0.12.
Published: 2024-11-01T14:17:49.773Z
Updated: 2026-04-28T16:10:08.265Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-44983 vulnerable 2026-06-08 06:12:41.567281 WordPress Aruba HiSpeed Cache Plugin <= 2.0.6 is vulnerable to Sensitive Data Exposure
MEDIUM (5.3)
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Aruba.It Aruba HiSpeed Cache.This issue affects Aruba HiSpeed Cache: from n/a through 2.0.6.
Published: 2023-12-19T15:29:33.268Z
Updated: 2026-04-28T16:08:40.755Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.