Approved changes feed: RSS · Atom

cpe:2.3:a:webdevmattcrom:givewp_–_donation_plugin_and_fundraising_platform:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWebdevmattcrom (73aa66e4-6dc0-5eac-bd79-c67e4f6d933b)
ProductGivewp – Donation Plugin And Fundraising Platform (d576956f-c8bb-521e-bcd5-c478e00e9259)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-8353 vulnerable 2026-06-08 07:00:24.323241 GiveWP – Donation Plugin and Fundraising Platform <= 3.16.1 - Unauthenticated PHP Object Injection
CRITICAL (9.8)
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.16.1 via deserialization of untrusted input via several parameters like 'give_title' and 'card_address'. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to delete arbitrary files and achieve remote code execution. This is essentially the same vulnerability as CVE-2024-5932, however, it was discovered the the presence of stripslashes_deep on user_info allows the is_serialized check to be bypassed. This issue was mostly patched in 3.16.1, but further hardening was added in 3.16.2.
Published: 2024-09-28T02:04:28.213Z
Updated: 2026-04-08T17:20:44.645Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-5941 vulnerable 2026-06-08 06:56:18.053695 GiveWP – Donation Plugin and Fundraising Platform <= 3.14.1 - Missing Authorization to Authenticated (Subscriber+) Limited File Deletion
MEDIUM (5.4)
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to unauthorized access and deletion of data due to a missing capability check on the 'handle_request' function in all versions up to, and including, 3.14.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read attachment paths and delete attachment files.
Published: 2024-08-20T02:03:14.586Z
Updated: 2026-04-08T17:03:55.765Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-5940 vulnerable 2026-06-08 06:56:18.053076 GiveWP – Donation Plugin and Fundraising Platform <= 3.13.0 - Missing Authorization to Unauthenticated Event Settings Update
MEDIUM (6.5)
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'handle_request' function in all versions up to, and including, 3.13.0. This makes it possible for unauthenticated attackers to edit event ticket settings if the Events beta feature is enabled.
Published: 2024-08-20T02:03:19.791Z
Updated: 2026-04-08T17:25:42.022Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-3714 vulnerable 2026-06-08 06:43:51.265334 GiveWP – Donation Plugin and Fundraising Platform <= 3.10.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'give_form' shortcode when used with a legacy form in all versions up to, and including, 3.10.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-05-18T04:30:52.568Z
Updated: 2026-04-08T17:28:06.496Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-1424 vulnerable 2026-06-08 06:25:40.043837 GiveWP – Donation Plugin and Fundraising Platform <= 3.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The GiveWP – Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 3.5.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-04-09T18:59:19.094Z
Updated: 2026-04-08T17:19:54.183Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-4246 vulnerable 2026-06-08 06:16:11.895142 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.