Litespeed Cache
Approved changes feed: RSS · Atom
cpe:2.3:a:litespeedtech:litespeed_cache:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Litespeedtech (17a5e0b8-e24b-5a2d-86af-9f892cc83a4e) |
|---|---|
| Product | Litespeed Cache (26a2cdc8-f543-5236-bbfc-170ee10d13a2) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-109215 |
vulnerable | 2026-11-03 10:17:39.658034 |
LiteSpeed Cache <= 7.9.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via VPI Image Attribute Re-Serialization
MEDIUM (6.4)
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has enabled Viewport Images (VPI) and configured a VPI filename that matches an image the attacker can embed in user-generated content — such as a bbPress topic where Subscriber-level Participants are permitted to post replies containing raw img tags.
Published: 2026-10-29T09:25:35.290Z
Updated: 2026-10-29T10:45:41.071Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-116763 |
vulnerable | 2026-11-03 10:15:21.451211 |
LiteSpeed Cache <= 7.9.1 - Unauthenticated Stored Cross-Site Scripting via HTML Minifier Predictable Placeholder (md5(REQUEST_TIME) + two-pass str_replace)
MEDIUM (5.4)
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the HTML Minify option (O_OPTM_HTML_MIN) is enabled and a companion plugin renders stored comment content into a raw-text context such as a JSON-LD script block on the same page.
Published: 2026-10-29T09:25:36.034Z
Updated: 2026-10-29T10:45:40.785Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-76579 |
vulnerable | 2026-10-13 12:28:36.422890 |
LiteSpeed Cache <= 7.9 - Reflected Cross-Site Scripting via ESI 'esi' Parameter
MEDIUM (4.7)
The LiteSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'esi' parameter in all versions up to, and including, 7.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Exploitation requires that the attacker supply a validly signed 'esi' value in the GET query string while submitting a separate attacker-controlled 'esi' payload as a POST body field, relying on PHP's default $_REQUEST merge order to have the POST value take precedence at the point of execution.
Published: 2026-09-19T08:27:23.566Z
Updated: 2026-09-19T13:51:18.872Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-3375 |
vulnerable | 2026-06-08 08:01:18.528056 |
LiteSpeed Cache <= 7.7 - Unauthenticated Stored Cross-Site Scripting via QUIC.cloud CCSS/UCSS REST API Endpoints
HIGH (7.2)
The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the /wp-json/litespeed/v1/notify_ccss and /wp-json/litespeed/v1/notify_ucss REST API endpoints in all versions up to, and including, 7.7. These endpoints accept CSS content from QUIC.cloud callback notifications and store it to disk without sanitization. The stored content is later rendered inline frontend page loads without output escaping. The access control protecting these endpoints is IP-based validation that can potentially be bypassed when the WordPress site is deployed behind a reverse proxy, load balancer, or CDN with certain configurations. This makes it possible for unauthenticated attackers, under certain conditions, to inject arbitrary JavaScript into CCSS/UCSS content.
Published: 2026-05-27T07:45:55.498Z
Updated: 2026-05-27T10:28:19.176Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-12450 |
vulnerable | 2026-06-08 07:04:30.256862 |
LiteSpeed Cache <= 7.5.0.1 - Reflected Cross-Site Scripting
MEDIUM (6.1)
The LiteSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URLs in all versions up to, and including, 7.5.0.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2025-10-29T09:27:57.311Z
Updated: 2026-04-08T17:10:46.784Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-9169 |
vulnerable | 2026-06-08 07:00:26.832234 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-44000 |
vulnerable | 2026-06-08 06:45:53.387163 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-3246 |
vulnerable | 2026-06-08 06:41:52.771386 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-28000 |
vulnerable | 2026-06-08 06:33:25.299011 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-4372 |
vulnerable | 2026-06-08 06:16:12.204627 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.