Approved changes feed: RSS · Atom

cpe:2.3:a:spacetime:ad_inserter_–_ad_manager_&_adsense_ads:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSpacetime (600d9f5e-2a41-5ba1-8161-c7069e6e13b9)
ProductAd Inserter – Ad Manager & Adsense Ads (68f6ff6d-bd78-5585-a71b-dccb7e51faef)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-89097 vulnerable 2026-11-03 10:17:50.574073 Ad Inserter <= 2.8.18 - Authenticated (Subscriber+) Sensitive Information Disclosure in 'ai-debug-processing-fe' & 'ai-debug-meta' URL Parameters
MEDIUM (4.3)
The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.8.18 via the ai_wp_footer_hook. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive data including the server's internal IP address, PHP configuration, WordPress and theme versions, hardening constants, the plugin's full block matrix, and all post meta values including underscore-prefixed protected keys such as API tokens and private integration state written by other plugins.
Published: 2026-10-13T07:46:22.727Z
Updated: 2026-10-15T16:43:51.986Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-11983 vulnerable 2026-09-16 04:32:46.406747 Ad Inserter <= 2.8.16 - Missing Authorization to Block Visibility Bypass via ai_ajax
MEDIUM (5.3)
The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.8.16 due to a missing capability check in the `ai_ajax` function. This makes it possible for unauthenticated attackers to view the contents of ad blocks that an administrator has restricted to administrator-only visibility.
Published: 2026-08-06T11:29:20.345Z
Updated: 2026-08-06T15:00:43.027Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-11984 vulnerable 2026-09-16 04:32:45.688657 Ad Inserter <= 2.8.16 - Missing Authorization to Unauthenticated Header/Footer Code Disclosure via 'ai-debug-code' Parameter
MEDIUM (5.3)
The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.8.16 due to a missing capability check on the `ai-debug-code` URL-parameter. This makes it possible for unauthenticated attackers to view administrator-configured header and footer code blocks that have been disabled from public display.
Published: 2026-09-16T03:28:18.607Z
Updated: 2026-09-16T18:36:33.492Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-11900 vulnerable 2026-07-29 00:23:31.771313 Ad Inserter <= 2.8.16 - Insecure Direct Object Reference to Authenticated (Contributor+) Arbitrary Post Content Disclosure via 'data' Shortcode Attribute
MEDIUM (4.3)
The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to and including 2.8.16 via the 'data' attribute of the [adinserter] shortcode. This is due to the replace_ai_tags() function processing a {reusable-block-N} tag pattern that calls get_post_field('post_content', N) without verifying the requesting user's capability with current_user_can('read_post'), without restricting the post type to 'wp_block', and without checking the post status. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the full content of arbitrary posts including Private, Draft, Pending, Trashed, and password-protected posts owned by other users, by placing the shortcode in a post they own and previewing it.
Published: 2026-07-03T07:53:08.023Z
Updated: 2026-07-07T17:01:17.535Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-9280 vulnerable 2026-06-08 08:08:58.888567 Ad Inserter <= 2.8.15 - Reflected Cross-Site Scripting via URL Parameters in iframe Mode
MEDIUM (6.1)
The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URL Parameters in iframe Mode in all versions up to, and including, 2.8.15 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Exploitation requires that iframe mode (AI_OPTION_IFRAME) is enabled on at least one ad block displayed on the targeted page, which is a non-default but supported configuration commonly used for AdSense and JavaScript-based ads.
Published: 2026-06-06T02:28:34.218Z
Updated: 2026-06-06T11:43:59.185Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-11745 vulnerable 2026-06-08 07:04:28.860197 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-4668 vulnerable 2026-06-08 06:16:14.113433 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-4645 vulnerable 2026-06-08 06:16:14.065196 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.