Burst Statistics
Approved changes feed: RSS · Atom
cpe:2.3:a:burst-statistics:burst_statistics:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Burst Statistics (a90ef850-0211-5922-bcc1-f90d2eedb225) |
|---|---|
| Product | Burst Statistics (bbedab27-5777-5d50-87e2-3e18a6486fd7) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-1894 |
vulnerable | 2026-06-08 06:27:14.870096 |
Burst Statistics – Privacy-Friendly Analytics for WordPress <= 1.5.6.1 - Authenticated(Contributor+) Stored Cross-Site Scripting via burst_total_pageviews_count
MEDIUM (6.4)
The Burst Statistics – Privacy-Friendly Analytics for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'burst_total_pageviews_count' custom meta field in all versions up to, and including, 1.5.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note that this exploit only functions if the victim has the 'Show Toolbar when viewing site' option enabled in their profile.
Published: 2024-03-13T15:27:26.563Z
Updated: 2026-04-08T17:34:22.170Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0405 |
vulnerable | 2026-06-08 06:22:00.594715 |
Burst Statistics Really Simple Plugins <= 1.5.3 - Authenticated (Editor+) SQL Injection
HIGH (7.2)
The Burst Statistics – Privacy-Friendly Analytics for WordPress plugin, version 1.5.3, is vulnerable to Post-Authenticated SQL Injection via multiple JSON parameters in the /wp-json/burst/v1/data/compare endpoint. Affected parameters include 'browser', 'device', 'page_id', 'page_url', 'platform', and 'referrer'. This vulnerability arises due to insufficient escaping of user-supplied parameters and the lack of adequate preparation in SQL queries. As a result, authenticated attackers with editor access or higher can append additional SQL queries into existing ones, potentially leading to unauthorized access to sensitive information from the database.
Published: 2024-01-17T04:32:16.771Z
Updated: 2026-04-08T17:29:23.394Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-5761 |
vulnerable | 2026-06-08 06:19:44.669093 |
Details available
CRITICAL (9.8)
The Burst Statistics – Privacy-Friendly Analytics for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'url' parameter in versions 1.4.0 to 1.4.6.1 (free) and versions 1.4.0 to 1.5.0 (pro) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2023-12-07T02:00:05.488Z
Updated: 2024-08-02T08:07:32.680Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.