Display Custom Fields In The Frontend Post And User Profile Fields
Approved changes feed: RSS · Atom
cpe:2.3:a:vegacorp:display_custom_fields_in_the_frontend_-_post_and_user_profile_fields:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Vegacorp (6fb912ff-62de-5bf5-8a52-0b0e12a6801b) |
|---|---|
| Product | Display Custom Fields In The Frontend Post And User Profile Fields (e0f05025-3a5b-52da-a3d0-1ba0af8be339) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2023-6996 |
vulnerable | 2026-06-08 06:21:56.566777 |
Display custom fields in the frontend – Post and User Profile Fields <= 1.2.1 - Authenticated (Contributor+) Code Injection
HIGH (8.8)
The Display custom fields in the frontend – Post and User Profile Fields plugin for WordPress is vulnerable to Code Injection via the plugin's vg_display_data shortcode in all versions up to, and including, 1.2.1 due to insufficient input validation and restriction on access to that shortcode. This makes it possible for authenticated attackers with contributor-level and above permissions to call arbitrary functions and execute code.
Published: 2024-02-05T21:22:02.792Z
Updated: 2026-04-08T17:28:42.026Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-6982 |
vulnerable | 2026-06-08 06:21:56.524004 |
Display custom fields in the frontend – Post and User Profile Fields <= 1.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via vg_display_data
MEDIUM (6.4)
The Display custom fields in the frontend – Post and User Profile Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode and postmeta in all versions up to, and including, 1.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-02-05T21:21:39.283Z
Updated: 2026-04-08T16:44:50.937Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.