Approved changes feed: RSS · Atom

cpe:2.3:a:awesomesupport:awesome_support_–_wordpress_helpdesk_&_support_plugin:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAwesomesupport (8ed68a22-56c6-57fe-afac-2dcb187e35ae)
ProductAwesome Support – Wordpress Helpdesk & Support Plugin (f23673df-bc9e-5a81-904e-d46f34e65f85)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-103370 vulnerable 2026-11-03 10:15:48.891585 Awesome Support <= 6.4.1 - Authenticated (Custom+) Stored Cross-Site Scripting via Ticket Attachment MIME Confusion
MEDIUM (6.4)
The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpas_files' parameter in all versions up to, and including, 6.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the "Enable drag-n-drop uploader for ticket form" setting is enabled, as it is disabled by default.
Published: 2026-10-28T06:45:05.565Z
Updated: 2026-10-29T01:41:54.736Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-19946 vulnerable 2026-09-16 04:34:15.724067 Awesome Support <= 6.3.9 - Missing Authorization to Authenticated (Subscriber+) Arbitrary User Denial via 'user_id' Parameter
MEDIUM (4.3)
The Awesome Support plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 6.3.9. This is due to a missing capability check on the wpas_do_mr_deny_user() function, which unlike its counterpart wpas_do_mr_activate_user() does not enforce current_user_can('edit_users') or current_user_can('edit_user', $user_id), relying solely on a nonce that is not scoped to the target user. This makes it possible for authenticated attackers, with subscriber-level access and above, to set the mr_user_denied flag on any user account — including administrators — permanently blocking their moderated activation and dispatching a denial notification email to the victim.
Published: 2026-09-09T05:31:03.643Z
Updated: 2026-09-11T20:19:14.539Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-4654 vulnerable 2026-06-08 08:05:13.646043 Awesome Support <= 6.3.7 - Authenticated (Subscriber+) Insecure Direct Object Reference to Unauthorized Ticket Reply Access via 'ticket_id' Parameter
MEDIUM (5.3)
The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to, and including, 6.3.7. This is due to the wpas_get_ticket_replies_ajax() function failing to verify whether the authenticated user has permission to view the specific ticket being requested. This makes it possible for authenticated attackers, with subscriber-level access and above, to access sensitive information from all support tickets in the system by manipulating the ticket_id parameter.
Published: 2026-04-08T07:43:02.627Z
Updated: 2026-04-08T18:50:47.666Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-12641 vulnerable 2026-06-08 07:04:30.584976 Awesome Support – WordPress HelpDesk & Support Plugin <= 6.3.6 - Missing Authorization to Unauthenticated Role Demotion
MEDIUM (6.5)
The Awesome Support - WordPress HelpDesk & Support Plugin for WordPress is vulnerable to authorization bypass due to missing capability checks in all versions up to, and including, 6.3.6. This is due to the 'wpas_do_mr_activate_user' function not verifying that a user has permission to modify other users' roles, combined with a nonce reuse vulnerability where public registration nonces are valid for privileged actions because all actions share the same nonce namespace. This makes it possible for unauthenticated attackers to demote administrators to low-privilege roles via the 'wpas-do=mr_activate_user' action with a user-controlled 'user_id' parameter, granted they can access the publicly available registration/submit ticket page to extract a valid nonce.
Published: 2026-01-16T04:44:34.683Z
Updated: 2026-04-08T17:13:18.740Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-13567 vulnerable 2026-06-08 06:25:37.964900 Awesome Support – WordPress HelpDesk & Support Plugin <= 6.3.1 - Unauthenticated Sensitive Information Exposure Through Unprotected Directory
HIGH (7.5)
The Awesome Support – WordPress HelpDesk & Support Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 6.3.1 via the 'awesome-support' directory. This makes it possible for unauthenticated attackers to extract sensitive data stored insecurely in the /wp-content/uploads/awesome-support directory which can contain file attachments included in support tickets. The vulnerability was partially patched in version 6.3.1.
Published: 2025-04-01T05:22:45.718Z
Updated: 2026-04-08T16:42:17.833Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-0596 vulnerable 2026-06-08 06:22:01.451361 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-0595 vulnerable 2026-06-08 06:22:01.450953 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-0594 vulnerable 2026-06-08 06:22:01.449574 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.