Ppwp – Password Protect Pages
Approved changes feed: RSS · Atom
cpe:2.3:a:buildwps:ppwp_–_password_protect_pages:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Buildwps (2cfb53d3-6344-5f67-93b0-1110424e315f) |
|---|---|
| Product | Ppwp – Password Protect Pages (db54fd6f-59a7-58da-9ece-a0d83b2daf2a) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-3639 |
vulnerable | 2026-09-16 04:33:15.321209 |
PPWP – Password Protect Pages <= 1.9.21 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
MEDIUM (6.4)
The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `ppwp` shortcode attributes in all versions up to, and including, 1.9.21 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-08-13T07:37:52.468Z
Updated: 2026-08-28T22:44:31.722Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-11280 |
vulnerable | 2026-06-08 06:23:49.296893 |
PPWP – Password Protect Pages <= 1.9.5 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
MEDIUM (5.3)
The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.9.5 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as administrator.
Published: 2024-12-17T11:24:29.909Z
Updated: 2026-04-08T17:27:11.755Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0620 |
vulnerable | 2026-06-08 06:22:01.508459 |
PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass
MEDIUM (5.3)
The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.9 via API. This makes it possible for unauthenticated attackers to obtain post titles, IDs, slugs as well as other information including for password-protected posts.
Published: 2024-02-20T18:56:27.217Z
Updated: 2026-04-08T16:48:36.172Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.