Beaver Builder Page Builder – Drag And Drop Website Builder
Approved changes feed: RSS · Atom
cpe:2.3:a:beaverbuilder:beaver_builder_page_builder_–_drag_and_drop_website_builder:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Beaverbuilder (eb651092-abad-5bbd-92b5-76ba694ff462) |
|---|---|
| Product | Beaver Builder Page Builder – Drag And Drop Website Builder (4d04ee34-c4f1-5ae5-8185-4a9ce51ef011) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-18021 |
vulnerable | 2026-09-16 04:34:01.921380 |
Beaver Builder Page Builder <= 2.10.3.1 - Unauthenticated Arbitrary Shortcode Execution
MEDIUM (6.5)
The The Beaver Builder Page Builder – Drag and Drop Website Builder plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.10.3.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Published: 2026-09-08T11:30:00.546Z
Updated: 2026-09-08T16:54:04.470Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-2481 |
vulnerable | 2026-06-08 07:55:17.124242 |
Beaver Builder Page Builder – Drag and Drop Website Builder <= 2.10.1.1 - Authenticated (Author+) Stored Cross-Site Scripting via 'settings[js]'
MEDIUM (6.4)
The Beaver Builder Page Builder – Drag and Drop Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'settings[js]' parameter in versions up to, and including, 2.10.1.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-04-08T11:16:58.131Z
Updated: 2026-04-08T16:55:17.525Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-1231 |
vulnerable | 2026-06-08 07:49:07.917624 |
Beaver Builder Page Builder – Drag and Drop Website Builder <= 2.10.0.5 - Authenticated (Custom+) Missing Authorization to Stored Cross-Site Scripting via Global Settings
MEDIUM (6.4)
The Beaver Builder Page Builder – Drag and Drop Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `js` Global Settings parameter in all versions up to, and including, 2.10.0.5 due to missing capability checks on save_global_settings() function and insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Custom-level access and above who have been granted beaver builder access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-02-11T01:23:34.203Z
Updated: 2026-04-08T17:03:22.254Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-8897 |
vulnerable | 2026-06-08 07:45:21.426878 |
Beaver Builder Plugin (Lite Version) <= 2.9.2.1 - Reflected Cross-Site Scripting
MEDIUM (6.1)
The Beaver Builder – WordPress Page Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘'fl_builder' parameter in all versions up to, and including, 2.9.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2025-08-28T01:46:29.543Z
Updated: 2026-04-08T17:09:39.249Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-12934 |
vulnerable | 2026-06-08 07:04:31.224699 |
Beaver Builder – WordPress Page Builder <= 2.9.4.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Update
HIGH (8.1)
The Beaver Builder – WordPress Page Builder plugin for WordPress is vulnerable to unauthorized access and modification of data due to a missing capability check on the 'duplicate_wpml_layout' function in all versions up to, and including, 2.9.4.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary posts with the content of other existing posts, potentially exposing private and password-protected content and deleting any content that is not saved in revisions or backups. Posts must have been created with Beaver Builder to be copied or updated.
Published: 2025-12-23T09:20:01.516Z
Updated: 2026-04-08T17:18:40.037Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-12782 |
vulnerable | 2026-06-08 07:04:30.804748 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-12558 |
vulnerable | 2026-06-08 07:04:30.435295 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-11726 |
vulnerable | 2026-06-08 07:04:28.831571 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-9505 |
vulnerable | 2026-06-08 07:00:28.089621 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-9049 |
vulnerable | 2026-06-08 07:00:26.556943 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-7895 |
vulnerable | 2026-06-08 06:58:23.844720 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-4430 |
vulnerable | 2026-06-08 06:50:17.748389 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-3923 |
vulnerable | 2026-06-08 06:43:51.882499 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2925 |
vulnerable | 2026-06-08 06:35:27.716765 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-1080 |
vulnerable | 2026-06-08 06:25:39.189758 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-1074 |
vulnerable | 2026-06-08 06:25:39.178330 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-1038 |
vulnerable | 2026-06-08 06:25:39.043251 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-11832 |
vulnerable | 2026-06-08 06:23:50.494449 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0897 |
vulnerable | 2026-06-08 06:22:03.090751 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0896 |
vulnerable | 2026-06-08 06:22:03.090212 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-0871 |
vulnerable | 2026-06-08 06:22:03.037506 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.