Approved changes feed: RSS · Atom

cpe:2.3:a:sohelwpexpert:awesome_buttons:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSohelwpexpert (27eb4b54-6ec3-5650-b0d4-eb304c22611c)
ProductAwesome Buttons (1885945c-d942-5c50-a665-81c5f7d509ee)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-10148 vulnerable 2026-06-08 06:22:03.673781 Awesome buttons <= 1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via btn2 Shortcode
MEDIUM (6.4)
The Awesome buttons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's btn2 shortcode in all versions up to, and including, 1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-10-25T06:51:24.936Z
Updated: 2026-04-08T17:04:30.064Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.