Approved changes feed: RSS · Atom

cpe:2.3:a:mapster:mapster_wp_maps:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorMapster (6915f532-37b7-5d82-9a93-0b293b889c72)
ProductMapster Wp Maps (a46238e5-afcd-5f4a-9687-9695d281cf13)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-107743 vulnerable 2026-11-03 10:15:59.022837 Mapster WP Maps <= 2.0.5 - Unauthenticated Stored Cross-Site Scripting via 'config.loading.background' Parameter
HIGH (7.2)
The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.0.5. This is due to the /wp-json/mapster-wp-maps/save-mapmaker REST route being registered with a permission_callback that unconditionally returns true (no capability check, no nonce), together with the mapster_write_config_to_acf() helper only sanitizing string config values with sanitize_text_field() — which strips HTML tags but leaves quote characters intact — and the mapster_wp_map shortcode renderer in mapster_wordpress_maps_shortcode_display() concatenating the stored loading_background_color value into a single-quoted inline style attribute without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-29T09:25:36.733Z
Updated: 2026-10-29T10:35:36.566Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-12954 vulnerable 2026-10-13 12:28:40.329855 Mapster WP Maps <= 1.23.0 - Authenticated (Subscriber+) Arbitrary User Meta Write via 'acf-photo-gallery-groups' Parameter
HIGH (8.8)
The Mapster WP Maps plugin for WordPress is vulnerable to Arbitrary User Meta Write in all versions up to, and including, 1.23.0 via the `my_profile_update()` function. This is due to the function performing no nonce verification, no capability check, and no allowlist validation on the meta key supplied via the `acf-photo-gallery-groups` POST parameter before passing both the meta key and its corresponding value directly to `update_user_meta()`. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary user meta values, though privilege escalation is not possible.
Published: 2026-09-18T07:40:02.971Z
Updated: 2026-09-19T14:21:51.866Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-9044 vulnerable 2026-06-08 07:45:21.627115 Mapster WP Maps <= 1.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The Mapster WP Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple fields in versions up to, and including, 1.20.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with contributor-level permissions and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-09-26T03:25:34.873Z
Updated: 2026-04-08T17:16:05.449Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-9235 vulnerable 2026-06-08 07:00:26.983396 Mapster WP Maps <= 1.5.0 - Incorrect Authorization to Authenticated (Contributor+) Arbitrary Options Update
HIGH (8.8)
The Mapster WP Maps plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to an insufficient capability check on the mapster_wp_maps_set_option_from_js() function in all versions up to, and including, 1.5.0. This makes it possible for authenticated attackers, with contributor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
Published: 2024-10-25T06:51:25.526Z
Updated: 2026-04-08T17:17:44.002Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-13362 vulnerable 2026-06-08 06:25:37.440182 Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
MEDIUM (6.1)
Multiple plugins and/or themes for WordPress are vulnerable to Reflected Cross-Site Scripting via the url parameter in various versions due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2026-05-01T05:29:54.148Z
Updated: 2026-05-01T13:23:26.723Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-10592 vulnerable 2026-06-08 06:23:47.037974 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.